3 Replies Latest reply: Dec 1, 2009 9:27 AM by John Trembly RSS

New Networker client backup problem

earth2009

Hi,

 

Networker server version 7.4.4, client version 7.3.2 both running on identical OS Windows Server 2003 R2 Enterprise x64 Edition SP1.

 

We have a Clariion CX3-80 and Scalar i2k tape library fibre attached through a switch to the backup server.

 

All backups are configured to go through the Networker server, with no storage nodes configured.

 

I am trying to setup a backup of a new Networker client which is actually a web server (this is on the same domain as the backup server). The Networker software has been installed and properly configured on the client, the client has been created successfully through the NMC with all the correct aliases in the globals tabs.

 

I have tested ping and DNS forward/ reverse lookups for this client all resolves ok. When running a manual/ scheduled client backup from the server via a savegroup backup command I get the error message "logfile has no output <SEVERE> : Connection timed out" The daemon.log provides the error message below:

 

nsrexecd Warning, cannot resolve host 'x' to 'IP_ADDRESS', name server may be misconfigured

 

I have tested ping, traceroute and forward/ reverse lookup from client to server and all of these resolve fine with no issues. The client didn't have a servers file in the \legato\nsr\res folder so I have created one with the short and long names of the Networker server, then restarted the remote exec and power monitor services on the client, but it still fails the backup.

 

I have tried creating a new test group and adding the client to this but it still fails. We have many other web servers configured in exactly the same way and these backup every night without any issues. The only thing I haven't been able to complete successfully yet is to run a manual test backup from the client to the server, however I get the message below:

 

"save is not recognised as an internal/ external command" even when I run it from the legato installation folder?

 

Can you please assist me in troubleshooting this problem?

Thanks.

  • 1. Re: New Networker client backup problem
    dvillanu

    Hello,

     

    Looks like you have gone through many of the steps that EMC Software Support would ask you to do, I would suggest to add the Networker server and Networker client's IP, short and fully qualified names to the hosts file for each system.

     

    What are the switches you are using when you run the save command. I recommend that you run

     

    C:\Program Files\Legato\nsr\bin\>save -s <nw_server> -b <pool> C:\filename

     

    C:\filename to equal a file on the root of C:\.

     

    Danny Villanueva

  • 2. Re: New Networker client backup problem
    earth2009

    Hi Danny,

     

    Yes I already added the short and long names and IP addresses of the client in the Networker server hosts file and likewise for the client's hosts file but I still had the same issue.

     

    I actually found out that the problem was the client had 2 NIC cards with 2 IP addresses, 1 on a DMZ DNS suffix and another on a PRIVBACKUP DNS suffix and the IP address I had added in the Networker server host file had the DMZ (external) IP address. This was confirmed as we had other web server clients already added to the Networker server hosts file but on the PRIVBACKUP IP range. After changing this and saving the file, I did a DNS forward and reverse lookup from the Networker server and this resolved to the PRIVBACKUP IP address.

     

    I then did a probe savegroup backup of this client using "savegrp -pvvv -c <FQDN of client> -g "groupname"> c:\output.txt 2>&1" which worked and then the following night this client backed up successfully to the EDL and also cloned to tape.

     

    Thanks for your assistance.

  • 3. Re: New Networker client backup problem
    John Trembly

    Hi,

     

    I find it useful to test the RPC connectivity using the short name, long name and IP address from the client to the server and visa versa.  You would have seen the problem immediately by having success with only the IP address while getting failures when using the shortname and longname on the client.  You would have had success with all three while testing from the backup server.

     

    rpcinfo -p <shortname>

    rpcinfo -p <longname>

    rpcinfo -p x.x.x.x

     

    Note: After installing the client on a new machine, logout and then back in again to get the new PATH mappings so you can use RPCINFO.

     

    Cheers,

     

    John