1 2 Previous Next 19 Replies Latest reply: Jun 5, 2018 7:25 PM by Patric RSS

Unable to create filesystem

Ignes

Let me start  at the beginning..

 

The DD in question was setup with 2 x expansion shelves.

These shelves were removed without destroying the filesystem.

 

I am now trying to create a filesystem but receive the below error:

sysadmin@qrecnhedd670a# fi stat

The filesystem doesn't exist.

sysadmin@qrecnhedd670a# fi create

**** There is no storage available for creation.

 

sysadmin@qrecnhedd670a# storage show tier active

Active tier details:

Disk      Disks               Count   Disk         Additional

Group                                 Size         Information

-------   -----------------   -----   ----------   ---------------

dg0       1.2-1.4, 1.6-1.12   10      931.5 GiB    1 disk degraded

(spare)   1.1                 1       931.5 GiB

-------   -----------------   -----   ----------   ---------------

 

Disk    Disks            Progress   Remaining

Group   Reconstructing   (%)        (minutes)

-----   --------------   --------   ---------

dg0     1.5              22         134

-----   --------------   --------   ---------

 

Current active tier size: 8.1 TiB

Active tier maximum capacity: 51.8 TiB

 

Shelf Capacity License:

License           Model   Total      Used      Remaining

---------------   -----   --------   -------   ---------

CAPACITY-ACTIVE   ES30    43.6 TiB   0.0 TiB   43.6 TiB

---------------   -----   --------   -------   ---------

sysadmin@qrecnhedd670a#

 

Don't worry about the degraded disk as I manually failed a disk.

 

Any suggestions on how to manually delete the disk group to free up the storage to allow me to create the filesystem?

 

Thanks/

  • 1. Re: Unable to create filesystem
    Hrvoje Crvelin

    Have you tried removing and then adding storage first?

  • 2. Re: Unable to create filesystem
    dsu

    I have this same problem and you can not remove the storage

    "Enclosure 1 cannot be removed; there are disks in use."

  • 3. Re: Unable to create filesystem
    dsu

    Quite low the activity around this Data Domain Support Forum.

    And the internet is also low on Data Domain info.

    Well, I guess this is the best way to force seeking official support.

     

    As for my problem, I will like to find some simple way to fix this

    instead of having to (try to) reinstall the OS and wipe all settings.

    In a few days I guess I'll have to try a reinstall, if I don't find something.

  • 4. Re: Unable to create filesystem
    mikuszed

    Hey DSU,

     

    Hate to be that person - but did you open up a support ticket? You can do it at support.emc.com, once you're registered.

     

    Thanks,

     

    -Ed

  • 5. Re: Unable to create filesystem
    jbrooksuk

    Hello, reinstalling the DDOS will not fix the problem you have.

    You have disks in enclosures that still contain DD data, they will still be the same after a DDOS re-install - since that only affects the controller.

    The intention of this forum is not to force you into calling into support for help, far from it but 'not' destroying the filesystem and not removing them (logically) before removing/moving them (physically) does exactly what you are seeing for many reasons.

    Example: so that things like headswaps can work when you need to do a controller upgrade or replace a faulty controller.

     

    There are multiple steps that really you need the help of DD support for, since it's not always a simple step by step process, you need to understand multiple aspects as you go.

    I don't think it's a good idea for me to assume what you're seeing and outline possible steps here but support will help you get this resolved.

     

    Regards, Jonathan

  • 6. Re: Unable to create filesystem
    dsu

    I will not be here if I've done that. Is an old DD without support. That's why my previous comment about support.

  • 7. Re: Unable to create filesystem
    dsu

    jbrooksuk, I just want to destroy all storage data and start fresh. I don't care about old data from those disks.

    From the GUI I've managed to destroy the FS, and now File System State is "File system is currently destroyed"

    but when I try to create it (also from GUI), I get "The file system cannot be created because no storage was detected."

    and under Configure Storage, I have Tier Configuration: Active with one Existing enclosure.

     

    Here are a few command lines with their output:

    # filesys status

    The filesystem doesn't exist.

    # filesys destroy

    Filesystem is already destroyed.

    # filesys create

    There is no storage available for creation.

    # storage show summary

    Disk States   Active tier

    In Use        11

    Spare         1

    TOTAL DISKS   12

    # storage remove enclosure 1

    Enclosure 1 cannot be removed; there are disks in use.

    # storage remove enclosure 2 (the old one from where all the troubles began)

    Invalid enclosure id "2".

  • 8. Re: Unable to create filesystem
    PatrickBetts

    dsu,

     

    I'm from DataDomain Support.  I was wondering what your original filesys destroy command was?  Did you use "filesys destroy and zero"?  it can take a long time to run but that should wipe the disks out.  Also, have you tried rebooting the DataDomain and then creating the filesystem?  Please try those ideas (reboot first, then destroy and zero) and let me know the results.  Thanks in advance.

     

    Best Regards,

    Patrick Betts

    DataDomain NET TSE

  • 9. Re: Unable to create filesystem
    dsu

    Oh, support on the forum... That's nice. Thanks.

    Well, I've used the GUI command and I didn't need the zero, because I don't care about a wipe. Just the FS.

    Yes, I've tried a restart but didn't change a thing.

    And "# filesys destroy and-zero" gives me "Filesystem is already destroyed." and this is normal.

    The system problem was that I've removed the second enclosure BEFORE destroying the FS.

    Now my problem is how to let the system know that I don't need it to search for that enclosure anymore.

    And just to create the FS using only the available enclosure.

    SE "filesys destroy force" has the same result

    And all I have in destroy.log is:

    NOTICE: MSG-DDR-00002: fs_tool started

    FS-Tool: Checking col_state file:

    FS-Tool: Complete filesystem destroy - allowing:

    getting volume list with option 0x800001f: :

    num of vols found by VL_ALL_VOLS: 1:

    FS-Tool: Found 1 volumes:

    vol (vol1): attr (0x1):

    FS-Tool:  Number of volumes found: 1

    CPM: Discover on volume vol1:

    NOTICE: MSG-SL-00004: Volume vol1 is unavailable.

  • 10. Re: Unable to create filesystem
    jbrooksuk

    Hi dsu,

     

    Email me, I'll webex in - I've tried to construct something useful to you to follow but it's just going to frustrate you more.


    Regards, Jonathan

  • 11. Re: Unable to create filesystem
    dsu

    A remote session is to be avoided for security reasons, especially with forum contacts and not official support.

    But maybe somebody else will like to help with telling me the few commands I need to run to fix this. Thanks anyway.

  • 12. Re: Unable to create filesystem
    jbrooksuk

    Hi dsu,

     

    I'm sorry that a WebEx is not possible, as discussed by email with you via my EMC email address - I cannot outline the steps in full because there are many aspects to understand as you work through this scenario.

    My intention was to help you as a favour from EMC via Webex, not to concern you over security.

     

    As also discussed, since you don't have a support contract with EMC, perhaps a T&M visit by your local EMC CE may be an option for you to resolve this.

     

    I will of course now step out of your forum thread so that you can pursue other means to resolve this with other EMC forum users.

    Sorry I couldn't help you.

     

    Regards,

    Jonathan

  • 13. Re: Unable to create filesystem
    dsu

    OK, so no more ideas around. Well, I guess the only option will be an OS reinstall on Monday.

    I'll let you (anyone with this same problem) know if that helps. Too bad Ignes didn't shared his solution.

  • 14. Re: Unable to create filesystem
    Ignes

    Hi,

     

    I ended up trashing the config with the USB disk and starting from scratch.

1 2 Previous Next