7 Replies Latest reply: Apr 23, 2013 12:33 PM by rmartis RSS

"No VM" error when running VMware guests image level

fdxpilot

Has anyone ever seen the "No VM" error when running VMware guest image-level backups?  There is no information in the GUI logs for these jobs.  When kicking off a manual backup the GUI reports:

 

Group backup request initiating...

Incomplete backup.

Virtual machines that are no longer addressable

through vCenter cannot be backed up.

 

Group backup request initiated.

 

The VM is present in vSphere and there are no tasks indicating anything out of the ordinary has happened to the VM since backup stopped working. Around the same time as the backup stopped working, vCenter tried to migrate the VM to another host and got an error "An error occurred while communicating with the remote host".  I have since migrated the VM to a different host in the same cluster and the Avamar backup error persists.

 

Support has suggested retiring the client and re-importing it.  That would probably work but I'm trying to understand what causes this issue so we can fix it and avoid cluttering our already large environment with many instances of the same clients over time.  Their theory is that Avamar somehow lost communication with vCenter or that the UUID of the VM has changed.  I can get the current UUID from vSphere but how can I see what Avamar thinks the UUID should be?  Support didn't know how to do this off the top of his head.  The SR is 49195034 if anyone from EMC is interested in looking at the history.


Thanks!

  • 1. Re: "No VM" error when running VMware guests image level
    fdxpilot

    Found the GUID in mcdb using this query:

     

    select cid, vm_real_name, uuid from vm_client where vm_real_name = 'nameofvm' ;

     

    It is different from the current GUID per vSphere.  Any way to get these back in sync?

  • 2. Re: "No VM" error when running VMware guests image level
    Lucky85

    Hello,

    I saw this problem when customer moved virtual clients to different lun, some moved machines appear as new one. You can check it when you try to add machine to avamar again, or you can check it in policy in client properties if you will see lun. I have retired old clients and add it again.

     

    Regards

    Lukas

  • 3. Re: "No VM" error when running VMware guests image level
    fdxpilot

    The weird thing is when you go to "Import multiple clients" into the domain under Administration, the VMs with the "No VM" error show as already added (they are greyed out).

  • 4. Re: "No VM" error when running VMware guests image level
    hanu_raob

    I faced the same issue when customer restored one VM backup to new VM and then deleted original vm. Renamed the new VM to old VM name thinking that it will work. But Avamar does not assign the GUID that way..So I had to retire the VM and added freshly then assigned to groups etc.

  • 5. Re: "No VM" error when running VMware guests image level
    Rodreis

    I dont know why Avamar Server cannot reestablish the communication with vCenter. but in my environment I solved this:

     

    Open Avamar Console > Administration button > Services Administration Tab > open tree e go to  utility node > on right pane locate your vcenter > right click and select "Restart yourvcenter.com".

     

    In my case the backups working again after this. good luck

  • 6. Re: "No VM" error when running VMware guests image level
    gherrington

    I had this issue and we resolved it by Launching the MSC and in the administration/ Service administration / module / UtilityNode.  restart the ConnectEMC service.  Support basically told me that the node temporarily lost connection with the Vcenter.  It fixed the problem for about a week.  Then I move the Guest to another datastore and since then started getting it again.  For some reason I see this a great deal with Cloned servers as opposed to servers built from scratch

  • 7. Re: "No VM" error when running VMware guests image level
    rmartis

    The only way I found to get it back is to go into Avamar Administration and Retire the client in question, keeping the data for the retention period. In that same screen (Avamar Administration), highlight the VMware V-Center Domain and right click. Select NEW CLIENT and it will open another window. Client Type should be VMware Virtual Machine. Click on BROWSE to look for the new client. In the Virtual Machines window and under the VSPHERE VIEW, click on Host and Clusters. Go to the LEFT PANE and look for the ESX Host that the VM resides on. Left click on ESX Host and Left Click on the Virtual Machine and click OK. You will need to do this because you can not locate the Virtual Machine under the list of Virtual Machines. For some reason, the Virtual Machine is not showing up where they should, under the Virtual Machines and Templates section..