2 Replies Latest reply: Aug 22, 2011 5:10 AM by witchedwiz RSS

Learning DFS from scrath: issue with setting things up


The title covers pretty much the problem..

Along the last months I've covered xCp, webtop customization and dfc..

Now I need to use DFS for some webservices and the thing is proving a chore.. But a chore at a VERY basic level..

I've downloaded via powerlink the development guide and successfully checked that the dfs are installed (to be on the safe side, I installed them as a separate deploying on tomcat so it ain't answering on 9080 method server but on 8080/emc-dfs/etcetc)..

I checked the preinstalled webservice and they are available on the application server, but....


I've tried working on my eclipse (3.6) with added composer dependancy&all, axis plugin and a few more plugin i usually use in development..

At first i tried to "improvise" following common sense..

1) Created a new dynamic web project

2) added an axis2 facet for the various library

3) added dfs library

4) saved the two wsdl from the remote location and added to the project

5) generated proxies via wdsl2java axis2 plugin (graphical interface, no command line) using default settings (adb binding)

6) now... before I add the proxies I get a missing import&unabletoretrieveclass error relative to the two stubs (stub for contextservice and schemaservice)... if i properly add the proxies I get a NICE error since during proxies generation I get a few class re-declared (like identity, and servicecontext, etc)..

Issue is: those generated class are either "messed up" with autogeneration or are messed up to begin with, since they redefine some methods..

for example serviceContext.getIdentities().add(identity); pre-proxy generation is a valid code row..

post code generation is invalid, because getIdentities get switched from a List<Identity> to a Identity[] where the add is not valid... and like that there are a plethora of similar error if i try to chase down the issue (es: GetRepositoryInfoResponse response = stub.getRepositoryInfo(get); getrepositoryinfo returns a GetRepositoryInfoResponseE, not a GetRepositoryInfoResponse)..

so i guess that's not working as intended and follow the canonical route..


if I instead follow the "guide"

1) Create a new documentum project

2) add axis2 lib

3) add the two java files Axisdfsconsumer and axisdfsnoregistrationconsumer and the build files (properties and build.xml)

4) edit the java files with login information and service location

5) edit the build files to match exact folder/service location

6) run build all

since there are no proxies the only notable error beforehand is the notification for missing stubs.. w/e, they supposedly should be generated by the ant build.

instead i get in the compile phase

D:\workspace_learn\AxisDfs\src\AxisDfsConsumer.java:1: cannot find symbol
    [javac] symbol  : class RepositoryIdentity
    [javac] location: package com.emc.documentum.fs.datamodel.core.context
    [javac] import com.emc.documentum.fs.datamodel.core.context.RepositoryIdentity;

issue is... the IDE finds them regularly in the code and they are in the classpath as library....

and of course i get errors like

D:\workspace_learn\AxisDfs\src\AxisDfsConsumer.java:62: cannot find symbol
    [javac] symbol  : method get(int)
    [javac] location: class com.emc.documentum.fs.datamodel.core.context.Identity[]
    [javac]                 serviceContext.getIdentities().get(0)).getRepositoryName());


(that are referring to mismatch in available methods in class, like i found while doing the whole round-up without following the guide).


Environment info:

Eclipse 3.6 (with all composer dependancy&plugin), java 1.6 (tested too with compliance level 1.5) and axis2 1.6.0

Eclipse Composer 6.6 , java 1.6 (tested too with compliance level 1.5) and axis2 1.6.0


Any advice? What's the abysmally noobish error I'm doing?    

  • 1. Re: Learning DFS from scrath: issue with setting things up


    I tried to build a stub+client from scratch for invoking webservice and received at first some mixed result that bugged me...

    1) pure documentum project (with no axis, nothing) --> webservice invocation successful

    2) pure dynamic web project (PLUS axis) --> error with a nice and talkative stack..

    com.emc.documentum.fs.rt.ServiceInvocationException: Service "com.emc.documentum.fs.services.core.QueryService" is not available at url: ""
        at com.emc.documentum.fs.rt.context.impl.DfsSoapService.newWebServiceClient(DfsSoapService.java:172)
        at com.emc.documentum.fs.rt.context.impl.DfsSoapService.init(DfsSoapService.java:62)
        at com.emc.documentum.fs.rt.context.impl.DfsSoapService.getBindingProvider(DfsSoapService.java:55)
        at com.emc.documentum.fs.rt.context.impl.HttpSessionInvocationHandler.invoke(HttpSessionInvocationHandler.java:54)
        at com.emc.documentum.fs.rt.context.impl.RemoteServiceInterfaceInvocationHandler.invoke(RemoteServiceInterfaceInvocationHandler.java:30)
        at com.emc.documentum.fs.rt.context.impl.ReturnedContentTransformationHandler.invoke(ReturnedContentTransformationHandler.java:45)
        at com.emc.documentum.fs.rt.context.impl.OperationOptionsHandler.invoke(OperationOptionsHandler.java:71)
        at com.emc.documentum.fs.rt.context.impl.ContextThreadLocalInvocationHandler.invoke(ContextThreadLocalInvocationHandler.java:51)
        at com.emc.documentum.fs.rt.context.impl.ServiceContextInvocationHandler.invoke(ServiceContextInvocationHandler.java:30)
        at $Proxy14.execute(Unknown Source)
        at com.wiz.test.ClientAlternative.main(ClientAlternative.java:70)

    Here in suspected that i had some proxy issue :X

    Caused by: java.lang.NoClassDefFoundError: javax/xml/ws/soap/AddressingFeature$Responses
        at org.apache.axis2.jaxws.binding.SOAPBinding.<init>(SOAPBinding.java:53)
        at org.apache.axis2.jaxws.binding.BindingUtils.createBinding(BindingUtils.java:45)
        at org.apache.axis2.jaxws.BindingProvider.initialize(BindingProvider.java:107)
        at org.apache.axis2.jaxws.BindingProvider.<init>(BindingProvider.java:77)
        at org.apache.axis2.jaxws.client.proxy.JAXWSProxyHandler.<init>(JAXWSProxyHandler.java:118)
        at org.apache.axis2.jaxws.client.proxy.JAXWSProxyHandler.<init>(JAXWSProxyHandler.java:109)
        at org.apache.axis2.jaxws.spi.ServiceDelegate.getPort(ServiceDelegate.java:622)
        at org.apache.axis2.jaxws.spi.ServiceDelegate.getPort(ServiceDelegate.java:514)
        at javax.xml.ws.Service.getPort(Service.java:92)
        at com.emc.documentum.fs.services.core.QueryService.getQueryServicePort(QueryService.java:62)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:597)
        at com.emc.documentum.fs.rt.context.impl.DfsSoapService.newWebServiceClient(DfsSoapService.java:156)
        ... 10 more

    Here i suspected that i was doing something stupid with the classpath but noticed axis2 in the stack, whilst technically the axis2 library were just included but never formally called! prohint suspect everything!
    Caused by: java.lang.ClassNotFoundException: javax.xml.ws.soap.AddressingFeature$Responses
        at java.net.URLClassLoader$1.run(URLClassLoader.java:202)
        at java.security.AccessController.doPrivileged(Native Method)
        at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
        at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
        at java.lang.ClassLoader.loadClass(ClassLoader.java:248)
        ... 25 more

    again classnotfound?? mmm


    puzzled by the double classnotfound i suspected it was some classpath issue...

    boy was i wrong!

    As soon as i defined a NEW dynamic web projext WITHOUT axis2 1.6 aspect...

    tadaaaa all worked like a charm..

    Where does that leave me?

    I'm starting to consider that dfs 6.6 ain't working with axis2 1.6, so what's the most recent axis2 version working properly with dfs 6.6? or i'm doing something wrong?

    And, considering that i'll be working with dfs 6.7 any news on the latest supported axis2?

  • 2. Re: Learning DFS from scrath: issue with setting things up

    Where does that leave me?

    I'm starting to consider that dfs 6.6  ain't working with axis2 1.6, so what's the most recent axis2 version  working properly with dfs 6.6? or i'm doing something wrong?

    And, considering that i'll be working with dfs 6.7 any news on the latest supported axis2?


    bump? :/


    Messaggio modificato da witchedwiz