1 2 Previous Next 23 Replies Latest reply: Feb 10, 2013 9:47 PM by TonyJK Go to original post RSS
  • 15. Re: "Could not get Pool details" - VSI Provision Storage ?
    TonyJK

    Dear Chris,

     

    Yes, you are right.  We are running FLARE 29.

     

    When I run "naviseccli -h <SP A or B> getrg", it gives me all the Storage Groups in the Storage Array.

     

    When I run "naviseccli -h <SP A or B> storagepool -list", it says "Management Server - Virtual Provisioning Feature software is not installed or is unavailable".

     

    From the log file, I get a number of DEBUG message and finally an ERROR message as follow:

     

    .....

    .....

    2013-02-07 15:43:59,886 [9172] [24] DEBUG EMC.Solutions.VMware.Unified.Engine.StorageProcessorConnection - Collecting Pool details - Start

    2013-02-07 15:43:59,902 [9172] [24] DEBUG EMC.Solutions.CLARiiON.NaviSecCliAdapter.Engine.Connection - Executing command: storagepool -feature -info -isvirtualprovisioningsupported

    2013-02-07 15:44:00,401 [9172] [24] DEBUG EMC.Solutions.CLARiiON.NaviSecCliAdapter.Engine.Connection - Received response (Took 0m:0s.499ms) exit code: 19735 standard out: Usage:

    2013-02-07 15:44:00,401 [9172] [24] ERROR EMC.Solutions.CLARiiON.NaviSecCliAdapter.Engine.Connection - Command Execution: Error returned from Block Storage System.

    2013-02-07 15:44:00,401 [9172] [24] ERROR EMC.Solutions.VMware.Unified.Gui.provisioningUi.StorageType - System.Exception: Could not get Pool details.  ---> System.Exception: Could not get Pool details.  ---> System.Exception: Usage:

    2013-02-07 15:44:18,201 [9172] [ClientUIThread] INFO  EMC.Solutions.Utilities.Profile.AccessProfileAdapter - Edit Access Profile: Start

    2013-02-07 15:44:18,232 [9172] [ClientUIThread] INFO  EMC.Solutions.Utilities.Profile.AccessProfileList - Creating a DataSet for the access profiles to save to a file

    2013-02-07 15:44:18,248 [9172] [ClientUIThread] INFO  EMC.Solutions.Utilities.Profile.AccessProfileList - Savings all Access Profiles to C:\Users\administrator.COMPANY\AppData\Roaming\EMC\Unified Storage\Config\EMC_Credentials.xml by registry key EMC_Unified_Storage_VMware_Plugin

    2013-02-07 15:44:18,279 [9172] [ClientUIThread] WARN  EMC.Solutions.Utilities.Xml.XmlSerializer - Cipher data is not specified.

    2013-02-07 15:44:18,279 [9172] [ClientUIThread] INFO  EMC.Solutions.Utilities.Profile.AccessProfileList - Creating a DataSet for the access profiles to save to a file

    2013-02-07 15:44:18,326 [9172] [ClientUIThread] INFO  EMC.Solutions.Utilities.Profile.AccessProfileList - Savings all Access Profiles to C:\Users\administrator.COMPANY\AppData\Roaming\EMC\Unified Storage\Config\EMC_Credentials.xml by registry key EMC_Unified_Storage_VMware_Plugin

    2013-02-07 15:44:18,419 [9172] [ClientUIThread] INFO  EMC.Solutions.Utilities.Profile.AccessProfileAdapter - Edit Access Profile: End

     

    Your advice is sought.

  • 16. Re: "Could not get Pool details" - VSI Provision Storage ?
    Christopher Imes

    TonyJK,

     

    Awesome the logs have nailed the issue.  The fix would be to load the "ThinProvisioning" enabler.  In FLARE 28 and 29, when loaded, it shows up in the list as "VirtualProvisioning" which it is complaining about.  However, loaded in FLARE 30+, it will show as "ThinProvisioning". 

     

    The fix would be to load the enabler (imho it is a bug or we need to update our documents to suggest it is required).  If you check the array properties and the list of enablers loaded (Software tab), you will find that you don't have it loaded.  Are you licensed for it?  It wasn't until VNX we introduced a "base" install which for free included this (along with a handful of others).

  • 17. Re: "Could not get Pool details" - VSI Provision Storage ?
    Christopher Imes

    Tony,

     

    In the upper-right, can you move this to the "Everything VMware at EMC" section of the forums?  There should be a "Move To" button. 

     

    The engineers in charge of the VSI plug-ins monitor that section, and I would like them to also review.  Once moved, I'll summarize for the group.

     

    Thanks!

  • 18. Re: "Could not get Pool details" - VSI Provision Storage ?
    TonyJK

    Dear Chris,

     

    Done !

     

    Unfortunately, we don't have the Thin Provisioning Enabler License.

     

    We have another CX4 Storage Array running FLARE 30 (also without the Thin Provisioning Enabler License), when I run

    "naviseccli -h <SP A or B> storagepool -list", nothing is returned (No complaint).

     

    Just out of curiosity, what is "Everything xxx at EMC" sections for ?

     

    Thanks again.

     

     

  • 19. Re: "Could not get Pool details" - VSI Provision Storage ?
    Christopher Imes

    @Tony

     

    TonyJK wrote:

     

    EMC.Solutions.CLARiiON.NaviSecCliAdapter.Engine.Connection - Executing command: storagepool -feature -info -isvirtualprovisioningsupported

    2013-02-07 15:44:00,401 [9172] [24] DEBUG EMC.Solutions.CLARiiON.NaviSecCliAdapter.Engine.Connection - Received response (Took 0m:0s.499ms) exit code: 19735 standard out: Usage:

    2013-02-07 15:44:00,401 [9172] [24] ERROR EMC.Solutions.CLARiiON.NaviSecCliAdapter.Engine.Connection - Command Execution: Error returned from Block Storage System.

    2013-02-07 15:44:00,401 [9172] [24] ERROR EMC.Solutions.VMware.Unified.Gui.provisioningUi.StorageType - System.Exception: Could not get Pool details.  ---> System.Exception: Could not get Pool details.  ---> System.Exception: Usage:

     

     

    Could you manually run the same command the tool is trying to run?

     

    naviseccli -h  <SPA or SPB> storagepool -feature -info -isvirtualprovisioningsupported

     

     

    @EMC

     

    Knowing that both the product manager and several engineers involved with the VSI plug-in monitor this section, could you review the thread (can focus on the most recent comments and troubleshooting) and determine how he can get around the error message?  I assume if he installs the appropriate enabler (which he isn't licensed for) it should resolve it?  He is unable to provision via the VSI USM plug-in based on the required prereqs as documented.

     

    Then again, I may be missing something.

  • 20. Re: "Could not get Pool details" - VSI Provision Storage ?
    Christopher Imes

    "Everything {Microsoft/VMware/Oracle/SAP}... at EMC", are sections that was meant to be questions related to those technologies and there is nothing suggesting that it is limited to integration with EMC hardware. 

     

    There will be questions that may be better served in the specific application/host community or those that are better served posted to the community monitoring those specific to the array.  It is also fair to say that there are many people monitoring the full stack.  However, of course it is self-policing in that the community will make sure it gets routed to the right section where appropriate.

  • 21. Re: "Could not get Pool details" - VSI Provision Storage ?
    TonyJK

    Dear Chris,

     

    It says that the option -feature is not recoginzed.  Does the command for EMC VNX Array ?

     

    C:\Users\administrator>naviseccli -h  192.168.15.124  storagepool -feature -info -isvirtualprovisioningsupported
    Usage:
      storagepool [-type poolType] -create -disks disksList -rtype raidType
           [-description description][-name name]
           [-prcntFullThreshold  threshold][-skipRules]
      storagepool [-type poolType] -destroy -id poolID|-name poolName [-o]
      storagepool [-type poolType] -expand -id poolID |-name poolName
           -disks disksList [-skipRules][-o]
      storagepool [-type poolType] -cancelExpand -id poolID|-name poolName
      storagepool [-type poolType] -list [-id poolID |-name poolName]
           [-availableCap][-consumedCap][-currentOp][-description][-disks]
           [-diskType][-luns][-opState][-opStatus][-prcntOp][-rawCap][-rtype]
           [-prcntFullThreshold][-state][-status][-subscribedCap][-userCap]
           [-prcntFull]
      storagepool [-type poolType] -modify -id poolID|-name poolName
           [-description description][-newName newName]
           [-prcntFullThreshold  threshold][-o]
      thinlun -create -capacity capacity [-sq sizeQualifier]
           -poolId storagePoolID |-poolName storagePoolName
           -sp spID [-aa autoAssignment][-l lunNumber][-name lunName]
           [-offset logicalBlockAddress]
      thinlun -destroy -l lunNumber [-o]
      thinlun -list [-l lunNumber][-name lunName][-aa]
           [-alOwner][-at][-brwsp][-consumedCap][-default][-drivetype]
           [-etp][-itp][-lunbusytickssp][-lunidletickssp]
           [-nzrca][-offset][-opDetails][-owner][-poolName][-rtype][-rwrsp][-slct]
           [-snapshot][-sor][-state][-status][-uid][-userCap]
      thinlun -modify -l lunNumber [-aa autoAssign]
           [-name newLUNName][-sp newDefaultSPID][-o]
      thin -info  [-availableDisks][-isSupported][-minThinLUNSize]
           [-maxThinLUNs][-maxThinLUNSize][-maxThinPools][-numPools]
           [-numThinLUNs]

    Unrecognized option: (-feature).

     

    Thanks

  • 22. Re: "Could not get Pool details" - VSI Provision Storage ?
    Christopher Imes

    Tony,

     

    I'm starting to think that the requirements as documented need to be reviewed.  Can you open a ticket with support?  The VSI plugin is fully supported by EMC and so open the ticket on behalf of your array.

  • 23. Re: "Could not get Pool details" - VSI Provision Storage ?
    TonyJK

    Dear Chris,

     

    Thanks for your advice.

     

    I have previously opened a ticket with EMC, they replied that we bought the Storage Array from DELL, please contacted DELL.

     

    When I contacted DELL, they said they didn't know VSI !!!

     

    Anyhow, thanks for your advice.

     

    Thanks again

1 2 Previous Next