1 2 Previous Next 15 Replies Latest reply: Jan 18, 2012 9:47 AM by dynamox RSS

Removing DAE from configuration

gsrb18

We recently purchased a used CX500 system. I've wiped domain information and gained access to the system through Navisphere. It appears that 2 DAE's were removed while the system was shut down. There were many LUN's, Storage Groups and Raid Groups configured by the previous owner that were now in fault because of the missing DAE's. My intention is to wipe all of the Raid groups, Storage groups and LUN's and start over. I've managed to Unbind most of the LUN's, then delete the Raid Groups.

Here are my questions.

1. Some LUN's cannot be Unbound. I receive an error message "Being used by a feature of the storage system". How do I Unbind these LUN's

2. How do I get the system to stop looking for the missing DAE's?

3. There is also a list of hosts in the hosts tab from the previous owner that I'd like to remove but don't see a delete option.

 

That's a lot of questions but any assistance on any of them would be appreciated.

  • 1. Re: Removing DAE from configuration
    dynamox

    1) see if this helps

     

    https://community.emc.com/message/475177

     

    2) restarting Navisphere Management service does not help ? (http://spa/setup)

     

    3) Are these hosts listed in Connectivity Status ? Get into engineering mode (Ctrl+Shift+F12  ..contact EMC for password - edit by Glen) and see if you can purge them.

     

    Message was edited by: Glen Kelley

  • 2. Re: Removing DAE from configuration
    gsrb18

    Thanks dynamox.

    1) Unbinding the remaining LUN's is still not happening. Once in engineering mode, I do see a "~physical" storage group which all of the locked LUNs belong to. Any effort to remove the LUN's from the storage group produces a new error "Results from call to remove LUN(s) from storage group:SP A: Special storage group cannot be modified., SP B: Special storage group cannot be modified.
    -----------------------------


    When:Unknown
    Where:EV_ScsiPipe::_sendCommand() - Sense Data , EV_ScsiPipe::_sendCommand() - Sense Data
    Who:@(#)libconnect Revision 6.19.01.02.06 for NT-4.0 on 10/03/2005 15:25:45, @(#)libconnect Revision 6.19.01.02.06 for NT-4.0 on 10/03/2005 15:25:45

    Trying to unbind still results in the "Being used by a feature of the storage system" error message. All of the LUN's show up in the "Unowned LUNs" group. Thanks for the help and I'll keep searching.

    2) I've restarted the Management service, the Storage Processors etc. The missing DAE's finally went away in Navisphere. I now think that maybe one DAE is mis-identified. Bus 1 Enclosure 1 shows a number of drives missing and failed but in reality it's full of drives and looks to be functioning normally.

    3) I was able to clear the hosts from the Connectivity Status dialog. They are now gone.

  • 3. Re: Removing DAE from configuration
    dynamox

    1) Did you run this command to see what has a hold of the LUNs

     

    naviseccli -Address <ip> -User emc -Password emc -Scope 0 getlun -messner <lunid> -stack

  • 4. Re: Removing DAE from configuration
    gsrb18

    OK, tried the cli that you recommended. Results for all of LUN's that throw the "Being used by a feature of the storage system" are;

     

    Listed Driver:             K10SnapCopyAdmin

     

    I tried the command "-Scope 0 setfeature -off -feature sancopy -lun 1"

     

    Didn't produce any errors at the command line but when I run the first command again it still shows Listed Driver: K10SnapCopyAdmin

     

    As for the Bus 1 Enclosure 1 looking odd. The cables were not plugged in correctly. Plugged them in to the correct ports on the DAE and that enclosure looks fine now.

  • 5. Re: Removing DAE from configuration
    dynamox

    try this:

     

    "-Scope 0 setfeature -off -feature K10SnapCopyAdmin -lun <LUN#>"

  • 6. Re: Removing DAE from configuration
    gsrb18

    when I run that I get;

    usage: setfeature -on|-off [-feature rm|sancopy -lun lun_number|-lunuid uid]

    Specified feature not supported

  • 7. Re: Removing DAE from configuration
    dynamox

    Try -feature rm

     

    Sent from my Verizon Wireless 4GLTE Phone

  • 8. Re: Removing DAE from configuration
    gsrb18

    I tried that too.

    -Scope 0 setfeature -off -feature rm -lun 6

    Command not Supported

     

    After running -Scope 0 setfeature -off -feature sancopy -lun 6
    Event viewer on SB B shows

    'setfeature' called by 'me' (my-IP) with result: Success (Navisphere CLI command: )

     

    so it appears that sancopy does get stopped. The problem is that if I run it again a few minutes later, it says the same thing.

     

    Thanks again for your ideas. I'll continue to search for a solution. Is it your understanding that a process (K10SnapCopyAdmin) has a lock on those LUNs and that is preventing their modification? That's kind of the way I see it.

  • 9. Re: Removing DAE from configuration
    dynamox

    sure looks like either sancopy or snapview has a hold of it. Is this box under maintenance ?

  • 10. Re: Removing DAE from configuration
    gsrb18

    It's an ebay special. Maybe I should run the serials by support on the off chance it's still covered.

  • 11. Re: Removing DAE from configuration
    dynamox

    worth a shot. DId you get any enablers when you bought it ? I was thinking if you could remove sancopy/snapview enablers, bounce both SPs and then re-install them.

  • 12. Re: Removing DAE from configuration
    gsrb18

    I'm just getting back to this. I'm not sure how to remove the enablers. Would this be done through Navisphere? I see the ability to uninstall various software packages in there. In the meantime, I was able to connect to the system using EMCRemote. Just looking through the Windows logs I see some things that may be helpful in determining what has a lock on those LUNs. This one in particular comes up every so often;

     

    Event Type: Information

    Event Source: Clones

    Event Category: (1235)

    Event ID: 277

    Date:  11/11/2011

    Time:  5:25:57 PM

    User:  N/A

    Computer: CX500SPA

    Description:

    Clone Group quiesce LU request.

     

    I see all of the software applications installed in "Program Files\EMC" through EMCRemote. Is there something that I can kill through here to try and release the lock on the LUNs? For example there are activate.bat and deactivate.bat files under nearly every application. I also have access to services, task manager and regedit.

  • 13. Re: Removing DAE from configuration
    dynamox

    get into Engineering mode (Cntrl+Shift+F12 ..messner), right click on array, properties, software. There you can uninstall enablers,  do you really want to do that since you dont' have the software to re-install it ?

  • 14. Re: Removing DAE from configuration
    gsrb18

    I've been away for awhile. I wanted to follow up and close the thread. I removed SanCopy and that did not remove the lock. I then removed SnapView and that lifted the lock. I was then able to delete the unowned luns. Now the funny thing is that SnapView is still available and appears to be usable in Navisphere. The SnapView I removed was listed near the bottom of the list by itself as "-SnapView" with no version info listed. SnapView is still listed with version info further up the list. In any case I'm thrilled. Thanks for all of your help! I now have a usable SAN.

1 2 Previous Next