1 2 Previous Next 26 Replies Latest reply: Apr 2, 2012 10:14 AM by Rainer_EMC RSS

Backup Exec + VNXe3300 CIFS Share = Access denied?


I've moved all of my company's network drives to our new VNXe3300 CIFS file shares, and that went fairly well. However, after getting everybody moved, I started setting up Backup Exec. When adding Backup Exec 'User Defined Shares' the system comes back with access denied. I've logged into a computer as the Backup Exec service account, and it pulled up the shares fine. Why would the VNXe deny it access for backup? Am I missing something?





  • 1. Re: Backup Exec + VNXe3300 CIFS Share = Access denied?
    Rohan Raj Nv

    Hi, There are no configuration changes that need to be made on the VNXe for share level backup.

    It is all done on the Backup exec.

    In case you have connectioned the back Exec directly to the DM using the DM local user and backup using the NDMP protocol then we will be glad to help.

  • 2. Re: Backup Exec + VNXe3300 CIFS Share = Access denied?
    Matthew Brender

    Rohan - do you happen to know what Brandon has to do in Backup Exec to resolve the error?




  • 3. Re: Backup Exec + VNXe3300 CIFS Share = Access denied?
    Rohan Raj Nv

    Hi Matt,

    Brandon has to add the User name that is used to access the cifs share in the local admin group of the machine where the Backup exec is running and add the user in the admin group of VNXe using the cifs server mmc in case of share level backup.

    In case of NDMP backup open Unisphere > setting > share folder server setting > in the page check the ndmp option and set the password then use any of the share folder server ip address in the Backup exec and user name as NDMP and the password and it works fine.

    Note: for share level backup Brandon has to configure the user in such a way that the user gets access to all the shares with full rights.




  • 4. Re: Backup Exec + VNXe3300 CIFS Share = Access denied?

    The Backup Exec user is a member of the domain admins, and if I log in as the Backup Exec user, I can browse to \\VNXE shares. It works fine within Windows, however, within Backup Exec, it says that access is denied to enumerate the shares.


    It's moot at this point, though. I did a search of the VNXe's help, which made it sound like the VNXe only supports NDMP for Backup Exec. I installed the NDMP option, and it's working fine. Hurt a bit to ask for the $1000 for the NDMP option license for Backup Exec, though.

  • 5. Re: Backup Exec + VNXe3300 CIFS Share = Access denied?
    Rohan Raj Nv

    To be frank you can check with the Symantec team to help you set this up.

    Even if you open a case with VNXe technical support team they will tell that once you have access to share it is just the work on Backup exec to perform the backup.

    Rather than investing money first, we can give it a try with the Symantec support I am very sure they will help you in this.

  • 6. Re: Backup Exec + VNXe3300 CIFS Share = Access denied?

    If the Symantec team can make it work without the NDMP option - someone, please document this.  The NDMP Option with Backup Exec is the only thing that has properly worked for us when backing up CIFS folder share hosted our VNXe 3100 - perhaps the 3300 is different.....    We tried as many configurations as we could without NDMP, but all of them failed consistently.

  • 7. Re: Backup Exec + VNXe3300 CIFS Share = Access denied?

    I don't think the 3300 is all that different from the 3100 software wise. (Only reason we stepped up was the option for 10 GbE).


    I found a thread on Symantec regarding Celerra CIFS shares, and they stated that NDMP needed to be disabled for BackupExec to pick up those shares. Problem is, NDMP was disabled on my VNXe when I started. Only after I enabled it, and used the NDMP option did I get anywhere.

  • 8. Re: Backup Exec + VNXe3300 CIFS Share = Access denied?
    Matthew Brender

    @Mercutio - I just wanted to confirm you're right! The 3100 and the 3300 are both VNXe. Same architecture, same software, different form factor (2U vs 3U).

  • 9. Re: Backup Exec + VNXe3300 CIFS Share = Access denied?
    Rohan Raj Nv

    When share level backup is done we need to disable NDMP on the VNXe.

    VNXe technical support team would not support it since Backup exec is nothing but a host for us which mounts all the shares and backs it up.

    If all the clients in your environment are able to mount and access the share then Backup exec should also be able to.

    We would be very glad to help you resolve the issue, so if you can open a case with VNXe support team and Symantec and bring them in a conference so that we can fix this up.

  • 10. Re: Backup Exec + VNXe3300 CIFS Share = Access denied?

    Was anyone ever able to get this to work?


    I am in the same boat as Brandon.  I can see the CIFS shares from my backup exec server just fine, but BE itself won't see them. (same access denied message)


    I bought the NDMP option and that works fine, however I didn't realize I couldn't restore to a target other than the VNXe, which to me kind of defeats the purpose of a backup in the event of a catastrophic hardware failure, fire, etc.


    So I'm back to trying to get CIFS backup working.  Symantec support has been less than helpful, I've been waiting for a call back that keeps getting pushed off while they "look into it".


    Hopefully someone out there has the answer!



  • 11. Re: Backup Exec + VNXe3300 CIFS Share = Access denied?
    Matthew Brender

    Hey Dave - Rohan mentions that in this case there was just a need for the NDMP user account being added as described above.


    I saw a great post on a few other common snags here - http://www.buraguy.com/53/backup/emc-vnxe-data-protection-with-symantec-backup-exec/


    The following best practice guidelines will help you to use the Backup Exec NDMP Option effectively:

    1. Match the port number that Backup Exec uses to the port number that the VNXe’s NDMP service uses when you add an NDMP device. By default this should be port 10,000.

    2. Do not use software encryption for NDMP backup jobs, it is not supported and will fail your backup jobs.

    3. Create separate polices/jobs for NDMP backups so you can control NDMP specific settings, including software encryption.

    4. If your environment has NAS servers from two or more vendors that are listed on the Other tab, create a separate backup job for each vendor.



  • 12. Re: Backup Exec + VNXe3300 CIFS Share = Access denied?



    Thanks for the reply.  I didn't have any problems geting NDMP setup, however since you can only restore back to the VNXe, it does not really meet my disaster recovery needs.


    Since I need to be able to redirect my restores in an emergency, I'm back trying to get direct CIFS backup working with Backup Exec.  From everything I can tell, it "should" work.  I can browse the VNXe shares from the media server, the user the backup exec service is running as is in the administrator group on the VNXe, etc...


    But for some reason Backup Exec gives me an error to the effect that it can not access the shares....



  • 13. Re: Backup Exec + VNXe3300 CIFS Share = Access denied?



    Some backup products have an optional license that allows you to restore NDMP backup to a windows or unix server.


    For instance commvault. See here.





    Not sure about backup exec though. You'll need to check with them.


    With regards backing up the CIFs shares have you tried mounting as a drive letter to your backup server and backing up that way?



  • 14. Re: Backup Exec + VNXe3300 CIFS Share = Access denied?

    OK, so the issue with using the CIFS shares in lieu of NDMP was this:


    NDMP and the Backup Exec Remote Agents both use port 10000.  Even when NDMP is disabled from the GUI on the VNXe, it still responds on TCP 10000.  So what was happening is backup exec was trying port 10000 looking for it's remote agent.  Normally if the port is closed, it will fail and fall back to backup via windows shares.  Since it got an answer on port 10000, it failed trying to initialize the remote agent.


    One solution was to move the default port on backup exec:



    Alternatively EMC support said they could disable it but that would require root access and I would need to contact support to undo the change if I ever wanted to use NDMP again in the future.  So I went with the first approach.


    Still testing, but things seem to be working now....



1 2 Previous Next