IA Remoting - Installation

Note: The IA Remoting component must be installed on a web server first if client modules need to access the InputAccel Server remotely over an HTTP connection.

 

To install InputAccel Remoting:

 

  1. From the Installation Choices menu of the InputAccel setup program, select Step 4 – Install the InputAccel Web Components.
  2. If you are prompted to install prerequisite applications, click Install. The following are installed,
  • Crystal Reports for .NET Framework 2.0
  • Microsoft .NET Framework 2.0 SP 1
  • Microsoft Visual JSharp .NET v2.0 Redistributable
  • Microsoft Windows Installer 3.1
  • Microsoft WSE 3.0
  1. Click Next.
  2. In the License Agreement window, select I accept the terms in the license agreement, and then click Continue.
  3. In the Custom Setup window, select InputAccel Remoting as the feature to install, and then click Next.
  4. In the Destination Folder window, click Next to install to the default destination directories.
  5. In the Data Access Layer Registration window, enter the Login ID and Password credentials for connecting to the SQL Server, and then click Next. By default, Register the Data Access Layer with the InputAccel database is selected and the local Database server on Port 1433, and InputAccel Database are specified.
  6. In the InputAccel Web Site User Account window, specify the Username, Password, and Domain credentials for the Windows user account that will run the InputAccel Web Components website.
  7. In the InputAccel Web Components window, specify the following:
  1. In the InputAccel Server Connection Information window, specify the Server name and Server port of the InputAccel Server to which the InputAccel Remoting component must connect. Click Next.
  2. In the InputAccel remote Access window, specify a virtual web directory. This directory is used to enable client modules access to the InputAccel Server and the InputAccel Database. Click Next.
  3. Click Install and then click Finish.
  4. To verify that InputAccel Remoting is installed correctly:
    1. Start ScanPlus, RescanPlus, or IndexPlus in production mode.
    2. Specify the URL of the InputAccel Remoting server in the Server name field.
    3. Confirm that the module connects to the InputAccel system.

 

Troubleshooting:

 

Issue-1

 

Symptoms

I have my IARemoting server in an internal network (internal IP address) and having my firewall translating a real IP address to the internal one (NAT Translation).  Connecting to the IARemoting server internally through Scanplus/RescanPlus/IndexPlus works fine, but I cannot connect from an outside client.

Affected Products: InputAccel 6.0 SP1, 6.0

 

Cause

The IARemoting server responds to the client machines with it's own internal IP address which causes the client to try to connect to a fake internal IP address rather than the real IP address.

 

Resolution

To fix this, add these lines to your web.config file on the IARemoting server:

 

<channels>

    <channel ref="http" machineName="MACHINENAME or IP ADDRESS">

        <serverProviders>

            <formatter ref="binary" typeFilterLevel="Full" />

        </serverProviders>

    </channel>

</channels>