VxFLEX OS plugin script cannot connect to vCenter

           

   Article Number:     539761                                   Article Version: 2     Article Type:    Break Fix 
   

 


Product:

 

VxFlex Product Family,VxFlex OS,VxFlex Ready Node,VxRack Flex Series,VxRack Flex-PowerEdge 13G,VxRack Flex-PowerEdge 14G

 

Issue:

 

 

   

      Scenario   

   

      The ScaleIO plugin script fails to connect to vCenter because there is an invalid vCenter certificate.   

   

      Symptoms   

   

      When running the ScaleIO plugin script, it may yield the following error:   

   
Cannot connect to the vCenter. Run the script again. If the problem continue, reopen PowerCLI.    
   

      The error is vague due to the script suppressing and redirecting any type of error when connecting to vCenter to the above general response.   

   

      Impact   

   

      Unable to utilize the vCenter ScaleIO plugin   

                                                             

 

 

Cause:

 

 

   

      Root Cause   

   

      The vCenter may have an invalid certificate and the current PowerCLI configuration does not allow the connection to happen because of the invalid certificate.   

                                                             

 

 

Resolution:

 

 

   

      Workaround   

   

      Adjust the PowerCLI configuration to ignore the invalid certificate by running the following command on the Windows server running the ScaleIO plugin script:   

   
Set-PowerCLIConfiguration -InvalidCertificateAction ignore -confirm:$false    
   

      Run the ScaleIO plugin script, it should now be able to connect to vCenter.   

                                                             

 

 

Notes:

 

 

   

      Impacted Versions   

   

      All versions   

   

      Fixed In Version   

   

      N/A - Not a ScaleIO issue.