Powerpath/VE 6.6 throws mpapi error

           

   Article Number:     539931                                   Article Version: 3     Article Type:    Break Fix 
   

 


Product:

 

PowerPath/VE for VMware

 

Issue:

 

 

Issue with Powerpath/VE 6.6 and PowerMAX there is an error thrown as follows: PowerPath: emcp_mpapi: Error: Esxi 6.500000 is not supported   
   
     
                                                           

 

 

Cause:

 

 

PPVE 6.6 has this limitation on one of the PowerMAX integration feature (Host registration) where PowerPath reports active VM's information to PowerMAX array. This feature is applicable only for ESXi 6.7 & higher versions because of CIM provider class limitation from VMWare side. So any lower versions of ESXi will throw below warning messages in the logs.   
     
                                                           

 

 

Change:

 

 

New install or Upgrade to Powepath/VE 6.6                                                           

 

 

Resolution:

 

 

This error can be ignored since it logs this message for any lower ESXi versions than 6.7.