SourceOne Email Management - Volumes fail to close while using Microsoft Storage Replica shares for archive.

           

   Article Number:     540656                                   Article Version: 2     Article Type:    Break Fix 
   

 


Product:

 

SourceOne Email Management

 

Issue:

 

 

Volumes fail to close while using Microsoft Storage Replica shares for the archive.     
   
    SourceOne Archival process fails to archive EMX files on Microsoft Storage Replica shares and the below entries can be found on ExAsArchive.exe.log:   
        

     
      Creating Container '\\Storage_Replica_Share\archive$\Archive_Folder\201911\20191106213450.emxt'     
     
      Adding files in '\\Archive_Server\message_center\Message_Center\Archive_Folder\201911\20191106213450' to volume     
     
      Unable to write file \\Storage_Replica_Share\archive$\Archive_Folder\201911\20191106213450.emxt (0x8604253A) Unknown error (0x8003046A)     
     
      [Archive_Folder\201911\20191106213450] Failed to Record Volume to [\\Storage_Replica_Share\archive$\Archive_Folder\201911\20191106213450.emxt] (0) FLAGS(166) (0x86042713) Unable to write file \\Storage_Replica_Share\archive$\Archive_Folder\201911\20191106213450.emxt (0x8604253A) Unknown error (0x8003046A) [ExAsArchive.exe, CExContainerFile.cpp(485).CExContainerFile::AddFileGroup]        
      [%1] Failed to Record Volume to [%2] (%3!d!) FLAGS(%4!d!) (0x86042713) [Archive_Folder\201911\20191106213450] Failed to Record Volume to [\\Storage_Replica_Share\archive$\Archive_Folder\201911\20191106213450.emxt] (0) FLAGS(166) (0x86042713) [ExAsArchive.exe, VolumeSupport.cpp(2442).CVolObj::CreateContainer]   >Unable to write file \\Storage_Replica_Share\archive$\Archive_Folder\201911\20191106213450.emxt (0x8604253A) Unknown error (0x8003046A) [ExAsArchive.exe, CExContainerFile.cpp(485).CExContainerFile::AddFileGroup]        
          
                                                             

 

 

Cause:

 

 

While reviewing Storage Replica servers Event Viewer, found on the Primary replica server the below details:   
   
    Under Application and Services Logs -> Microsoft -> Windows ->Find and expand the Storage Replica.   
    Check Admin and Operational Logs.   

     
      Event Id 10004     
     
      There is not enough available memory.     
     
      Available memory: 3103883264     
     
      Guidance: When system memory is low, Storage Replica operates in a degraded state and reduces its own memory usage. Initial replication and block copy recovery will be slower than normal when in this state. To determine the cause of unknown memory conditions, use Resource Monitor, Performance Monitor, or the Windows Performance Analyzer tools. If the condition is expected, consider adding more physical memory.   
                                                             

 

 

Resolution:

 

 

In order to resolve the issue, you must increase the RAM resources on the affected Storage Replica servers.   
   
    After you complete the previous task, SourceOne will automatically close the affected volumes.