Avamar Hyperv Incremental with RCT backup stalls for many hours with no progress bytes in Avamar Admin GUI (Activity)

           

   Article Number:     540383                                   Article Version: 3     Article Type:    Break Fix 
   

 


Product:

 

Avamar

 

Issue:

 

 

Avamar Hyper-V Incremental Backup with RCT remains in "Running" state for many hours with no progress bytes in Activity then completes successfully.   
   
    There is no error in the log - backup is not showing any progress.   
    Only avhypervvss.exe and avagent.exe (from Avamar) processes are running (no avtar.exe in Task Manager) on the Primary Node.   
   
    The relevant portion from Avamar Backup Log shows that the backup is not progressing for many hours and printing  <RCTExtents Length="> messages for each and every RCT extent, about 650 thousand lines:   
   
    2020-01-15 00:11:42 avhypervvss Info <0000>:   <VmVhdMapList>   
    2020-01-15 00:11:42 avhypervvss Info <0000>:     <VhdMap VhdControllerNumber="0" IsUserSnap="false" UniqueID="########" VhdControllerType="IDE Controller 0" Child="##########.vhdx" ID="###############" Size="42949672960" VhdControllerAddress="0" DiskInstanceId="Microsoft:############\\######\\0\\0\\D" SnapId="">   
    2020-01-15 00:11:42 avhypervvss Info <0000>:       <RCTExtentsList>   
    2020-01-15 00:11:42 avhypervvss Info <0000>:         <RCTExtents Length="32768" Offset="1196032" />   
    2020-01-15 00:11:43 avhypervvss Info <0000>:         <RCTExtents Length="32768" Offset="31784960" />   
    .   
    .   
    .   
    2020-01-15 11:49:00 avhypervvss Info <0000>:         <RCTExtents Length="999424" Offset="101568512000" />   
    2020-01-15 11:49:00 avhypervvss Info <0000>:         <RCTExtents Length="999424" Offset="101569560576" />   
    2020-01-15 11:49:00 avhypervvss Info <0000>:         <RCTExtents Length="999424" Offset="101570609152" />   
    2020-01-15 11:49:00 avhypervvss Info <0000>:         <RCTExtents Length="58969522176" Offset="101571657728" />   
    2020-01-15 11:49:00 avhypervvss Info <0000>:       </RCTExtentsList>   
    2020-01-15 11:49:00 avhypervvss Info <0000>:     </VhdMap>   
    2020-01-15 11:49:00 avhypervvss Info <0000>:   </VmVhdMapList>   
    2020-01-15 11:49:00 avhypervvss Info <0000>:   <VhdList file_type="0" VhdSize="0" VhdFilePath="###########################.vhdx" />   
    2020-01-15 11:49:00 avhypervvss Info <0000>:   <RctIdsMap>   
    2020-01-15 11:49:00 avhypervvss Info <0000>:     <StringToStringMapEntry Value="rctX:###############:00000001#Microsoft:###############" Key="#############" />   
   
   
   
     
                                                           

 

 

Cause:

 

 

The --debug flag in avhypervvss.cmd on the Primary Hyperv Node exists or 'Debug' is enabled in the Backup Dataset.   
    Having debug enabled in incremental backup with RCT significantly slows down the backup job.   
   
     
                                                           

 

 

Resolution:

 

 

Disable 'Debug' for Hyperv plugin:   
    - un-check 'debug' in the Dataset for Hyperv plugin (in Advanced Options)   
    - remove --debug from all avhypervvss.cmd files in Avamar VAR