IDPA: vCenter shows exclamation mark next to it on the ACM UI and Error "Unable to get vCenter version" can be seen on the Virtualization dashboard

           

   Article Number:     538937                                   Article Version: 2     Article Type:    Break Fix 
   

 


Product:

 

Integrated Data Protection Appliance Family,Integrated Data Protection Appliance Hardware,Integrated Data Protection Appliance SW,DP4400 Appliance,DP5300 Appliance,DP5800 Appliance,DP8300 Appliance,DP8800 Appliance

 

Issue:

 

 

The following error can be seen on vCenter UI :       
       
        User-added image       
       
       
        From the above screenshot we can see that ACM was unable to fetch the vCenter version.       
        ACM 'server.log' can be reviewed for more details: (location: /usr/local/dataprotection/var/configmgr/server_data/logs/server.log)       
       
        The following error can be seen on the server.log:
     
     
      2019-11-04 13:00:46,164 INFO  [Thread-682]-util.SSHUtil: Remote command using SSH execution status:     Host     : [x.x.x.x]     User     : [root]       Password : [********************]       Command  : [version.get]        STATUS   : [127]       
        2019-11-04 13:00:46,164 INFO  [Thread-682]-util.SSHUtil:        STDOUT   : [bash: version.get: command not found^M]       
        2019-11-04 13:00:46,164 INFO  [Thread-682]-util.SSHUtil:        STDERR   : []       
        2019-11-04 13:00:46,164 ERROR [Thread-682]-util.SSHUtil: Failed to executed remote command using SSH.       
        2019-11-04 13:00:46,164 ERROR [Thread-682]-dashboard.VMwareComponentDashboardImpl: loadVMwareComponentDashboardResponse-->
Error while checking the power state of vCenter server. Reason:Unable to get vCenter version.   
   
   
     
                                                           

 

 

Cause:

 

 

This issue could be caused due to connectivity issue between ACM and vCenter Server. It can also be caused due to password sync issues or it could be a case where a command issued by ACM to fetch vCenter version fails. In the above scenario, ACM was able to successfully login to the vCenter server, however the command "version.get" failed on the vCenter with error "bash: version.get: command not found".       
        Note: "version.get" command only works on vCenter shell and not in bash mode. Hence we need to verify if the vCenter shell is enabled. If vCenter shell is disabled, that could cause this issue.
                                                           

 

 

Resolution:

 

 

1: Manually login to the vCenter server from ACM to verify the behavior:   

         
  •         ssh root@<vCenter_IP_Address_OR_FQDN>     
  •    
   
    2: Verify if the shell is enabled.       
       
        If the shell is enabled, the following output is seen:
     
      xxx-acm:/usr/local/dataprotection/var/configmgr/server_data/logs # ssh root@x.x.x.x       
        VMware vCenter Server Appliance 6.5.0.23000       
       
        Type: vCenter Server with an embedded Platform Services Controller       
       
        root@10.25.25.52's password:       
        Last login: Wed Nov 20 09:07:40 2019 from x.x.x.x       
        This vCenter is being managed and used by Integrated data protection appliance. Alteration of the vCenter configuration except at the explicit direction of Dell EMC support could result in an unusable system and lead to data loss.       
       
        WARNING: Adding unauthorized virtual machines to this system is a violation of your license and will result in loss of support       
        Connected to service       
       
            * List APIs: "help api list"       
            * List Plugins: "help pi list"       
            * Launch BASH: "shell"       
       
        Command>
     
     
      3: Issue the version.get command to verify it works:       
       
        Expected Output: 
     
      Command> version.get       
        Version:       
           Product: VMware vCenter Server Appliance       
           Installtime: 2019-08-06T11:07:03 EDT       
           Summary: Update for VMware vCenter Server Appliance 6.5.0       
           Releasedate: November 29, 2018       
           Version: 6.5.0.23000       
           Build: 10964411       
           Type: vCenter Server with an embedded Platform Services Controller
     
     
      4: If the shell is not enabled, the following output is seen upon ssh to vCenter Server:     
     
       xxxxacm:/# ssh root@x.x.x.x       
        VMware vCenter Server Appliance 6.5.0.31000       
       
        Type: vCenter Server with an embedded Platform Services Controller       
       
        root@x.x.x.x's password:       
        Last login: Mon Nov  4 13:09:08 2019 from x.x.x.x       
        This vCenter is being managed and used by Integrated data protection appliance. Alteration of the vCenter configuration except at the explicit direction of Dell EMC support could result in an unusable system and lead to data loss.       
       
        WARNING: Adding unauthorized virtual machines to this system is a violation of your license and will result in loss of support       
        root@xxxxxx [ ~ ]# version.get       
        -bash: version.get: command not found
     
     
      Note: In the above output, it is clear that vCenter shell is not enabled.       
       
        5: Enable the vCenter shell using the following command:
   
         
  •         chsh -s /bin/appliancesh root     
  •    
   
    6: Exit and relogin to vCenter to confirm the shell is enabled.       
       
        7: Refresh the ACM UI