IDPA Backup agents installation failed at 48% due to timeout

           

   Article Number:     538195                                   Article Version: 4     Article Type:    Break Fix 
   

 


Product:

 

Integrated Data Protection Appliance Software 2.4.1,Integrated Data Protection Appliance Software 2.3,Integrated Data Protection Appliance Family

 

Issue:

 

 

   

      IDPA Backup agents installation failed at 48% due to timeout as seen on Avamar Installation Manager UI:         
         
          The Avamar AVI UI can be accessed at the following address:         
          https://<AVAMAR_IP_ADDRESS_OR_FQDN/avi         
         
         
         
          User-added image         
         
         
          Note: This is applicable for IDPA versions 2.3.0 and greater (i.e. 2.3.1, 2.4.1, 2.5).          
         
          SYMPTOMS: 
   

   
         
  •         On ACM dashboard you will see a spinning wheel for backup agents installation in progress.      
  •      
  •         All backups will go into hung state.     
  •    
                                                             

 

 

Cause:

 

 

   

      Updating Avamar Client Plugin-Catalog times out for AVE -18.2.0-134_HF310588   

                                                             

 

 

Resolution:

 

 

The following steps need to be followed on IDPA Avamar :       
       
        1. Login to avamar using admin user and find the mcs pid.
   

      admin@: ~/>: netstat -anp|grep 7778 |grep LISTEN(Not all processes could be identified, non-owned process infowill not be shown, you would have to be root to see it all.)tcp        0      0 :::7778                 :::*                    LISTEN      3311/java    
   
    2. Kill the process   
      admin@:~/>: kill -9 3311    
   
    3. Prior to starting MCS, perform the following changes in mcserver.xml:   
      Before:<entry key="group_scheduler_enabled" value="false" />After:<entry key="group_scheduler_enabled" value="true" />    
       
        4. Then start up MCS
   
      admin@:~/>: mcserver.sh --start    
   
    5. When it is totally up, go to the AVI page retry. i.e.  https://Avamar-IP/avi/avigui.html       
        After the following steps are performed, we need to execute the below steps on ACM Side       
        Need to add below steps for ACM dashboard showing AV agents installation is in progress.
   
         
  1.         Create touch file “av_ucd_install_success” in folder /usr/local/dataprotection/var     
  2.      
  3.         Set idpauser permission on this file, see below command output     
  4.    
   
      ACM:/usr/local/dataprotection/var # chown idpauser:idpauser av_ucd_install_successACM:/usr/local/dataprotection/var # ls -latotal 0drwxr-xr-x 1 idpauser idpauser  62 Oct 13 21:14 .drwxr-xr-x 1 idpauser idpauser 390 Oct  6 23:16 ..-rw------- 1 idpauser idpauser   0 Oct 13 21:14 av_ucd_install_successdrwxr-xr-x 1 idpauser idpauser  22 Oct  3 08:52 configmgr    
        
       
        6. After that click on refresh dashboard icon to restart dashboard thread.       
        User-added image