ViPR Controller: UI fails to display volumes resulting in an Internal Server error

           

   Article Number:     537764                                   Article Version: 2     Article Type:    Break Fix 
   

 


Product:

 

ViPR Controller,ViPR Controller Controller 3.6,ViPR Controller Controller 3.5,ViPR Controller Controller 3.0

 

Issue:

 

 

The user navigates to Resources > Volumes in the ViPR Controller UI resulting in  "Internal Server Error" being displayed .   
   
    The apisvc log reports the following:   

      vipr5 apisvc 2019-09-27 08:49:24,788 [qtp1656303750-822]  INFO  RequestAuditFilter.java (line 64) Request: POST - https://<IP>:4443/block/volumes/bulk - empty-query from <IP>       
        vipr5 apisvc 2019-09-27 08:49:25,426 [qtp1656303750-822]  WARN  ServletHandler.java (line 546) /block/volumes/bulk       
        java.lang.NullPointerException
   
   
    The portalsvc log reports the following:   
      vipr5 portalsvc 2019-09-27 08:49:25,429 [play-thread-45] ERROR  Logger.java (line 604)        
        @7daac7agl       
        Internal Server Error (500) for request GET /resources.blockvolumes/volumesjson?projectId=urn%3Astorageos%3AProject%3A105fc723-bed4-4de0-a7b0-3a0728bf416c%3Aglobal&_=1569574163826       
        Execution exception       
        WebApplicationException occured : javax.xml.bind.UnmarshalException  - with linked exception: [org.xml.sax.SAXParseException; lineNumber: 1; columnNumber: 570933; XML document structures must start and end within the same entity.]       
        play.exceptions.JavaExecutionException: javax.xml.bind.UnmarshalException       
         - with linked exception:       
        [org.xml.sax.SAXParseException; lineNumber: 1; columnNumber: 570933; XML document structures must start and end within the same entity.]
   
                                                             

 

 

Cause:

 

 

Invalid volume records in the ViPR Controller DB result in a parsing exception.   
     
                                                           

 

 

Resolution:

 

 

   

      A solution exists for this issue, but intervention from DellEMC technical support personnel is required.     
      Support personnel must access your storage system to fix this issue.     
      Contact the DellEMC Customer Support Center or your service representative for technical assistance and quote this article ID.     
     
      Note: the ViPR Controller Database Consistency check will not resolve this issue