Data Protection Advisor (DPA): Analysis Engine fails to send SNMP traps or update Windows events after upgrade to 19.1

           

   Article Number:     537383                                   Article Version: 2     Article Type:    Break Fix 
   

 


Product:

 

Data Protection Advisor Family

 

Issue:

 

 

After upgrading to 19.1 B48 an existing ruleset is no longer sending out SNMP traps or updating the Windows Event logs.  This ruleset was functioning correctly before the upgrade.    
   
    The following errors are seen in the server logs with Analysis Engine in debug:   
   
    2019-08-27 10:02:37,746 DEBUG [com.emc.dpa.analysis.AnalysisAlertServiceBean] (EJB default - 86) Requested to send an SNMP trap for alert on rule <rule_name> with policy <policy_name> host: <App_server_IP>       
        2019-08-27 10:02:37,747 DEBUG [com.emc.dpa.analysis.AnalysisAlertServiceBean] (EJB default - 86) Requested to send an SNMP trap for alert on rule <rule_name> with policy >policy_name> host: <App_server_IP>       
        2019-08-27 10:02:37,747 ERROR [org.jboss.as.ejb3] (EJB default - 86) javax.ejb.EJBTransactionRolledbackException: Unexpected Error
   
     
                                                           

 

 

Cause:

 

 

This is a known Bug/Defect in Data Protection Advisor.   
     
                                                           

 

 

Resolution:

 

 

To be resolved in a patch above Data Protection Advisor 19.1.0 patch b61.       
        The Patch will be available through Dell EMC Technical Support.
   
   
   
    Contact DPA Technical Support team for any additional information