VPLEX: Error with RecoverPoint username and password (WARNING:Username or Password is not valid for 'https://xx.xx.xxx.xxxx:7225/fapi/version3_5?wsdl'.)

           

   Article Number:     536541                                   Article Version: 4     Article Type:    Break Fix 
   

 


Product:

 

VPLEX VS6,VPLEX VS2,VPLEX for All Flash,VPLEX GeoSynchrony,VPLEX GeoSynchrony 5.4 Service Pack 1,VPLEX GeoSynchrony 5.4 Service Pack 1 Patch 1,VPLEX GeoSynchrony 5.4 Service Pack 1 Patch 3,VPLEX GeoSynchrony 5.4 Service Pack 1 Patch 4

 

Issue:

 

 

Issue:   
    Listing of RecoverPoint clusters in VPLEX shows below warning message :   
   
    VPlexcli:/>ll /recoverpoint/rpa-clusters     
      WARNING:  Username or Password is not valid for 'https://10.241.xxx.xxx:7225/fapi/version3_5?wsdl'.     
      WARNING:  Username or Password is not valid for 'https://10.241.xxx.xxx:7225/fapi/version3_5?wsdl'.     
      WARNING:  Username or Password is not valid for 'https://10.241.xxx.xxx:7225/fapi/version3_5?wsdl'.     
     
      /recoverpoint/rpa-clusters:      
      RPA Host       VPLEX Cluster  RPA Site  RPA ID  RPA Version     
      -------------  -------------  --------  ------  -----------     
      10.241.xxx.xxx  cluster-1        -         -       -
                                                           

 

 

Cause:

 

 

If end user had changed the admin account password on RecoverPoint and/or service account password on VPLEX then while listing the RecoverPoint details in VPLEX it will throw the warning message stating "Username or Password is not valid for 'https://10.241.xxx.xxx:7225/fapi/version3_5?wsdl'".                                                           

 

 

Change:

 

 

Possibly changed the Admin password for RecoverPoint and/or Service password for VPLEX.                                                           

 

 

Resolution:

 

 

Please follow the below steps in order to resolve the issue:   
   
    1. Please check and confirm the connectivity between VPLEX and RecoverPoint by running below   
        set of command's from the VPLEX cluster-1 management server and/or Cluster-2 management   
        server if RecoverPoint is configured there or this is a MetroPoint. .   

         1.a) Please run the below command to check the RPA IP address:     
                    
                 The following cli command will return the RPAs info per cluster with their IP addresses and     
                 RPA version listed.     
     
      VPlexcli:/> ll /recoverpoint/rpa-clusters/    

   

      /recoverpoint/rpa-clusters:       
        RPA Host       VPLEX Cluster  RPA Site  RPA ID  RPA Version       
        -------------  -------------  --------  ------  -----------------       
        10.241.xxx.xxx  cluster-1      RP_VPLEX  RPA 1   5.0.SP1.P3(e.285)       
           \__ IP Address                                \_ RPA version running
   

   
    Ping:   
    service@ManagementServer:~> ping x.x.x.x << Recover-Point cluster ip-address   
    PING x.x.x.x(x.x.x.x) 56(84) bytes of data.     
      64 bytes from x.x.x.x: icmp_seq=1 ttl=64 time=0.252 ms     
      64 bytes from x.x.x.x: icmp_seq=2 ttl=64 time=0.229 ms     
      64 bytes from x.x.x.x: icmp_seq=3 ttl=64 time=0.237 ms
   
   
    SSH:   
    service@ManagementServer:~> ssh admin@x.x.x.x >> Recover-Point cluster ip-address   
    Password:      
      Last login: Tue Jul 30 08:04:35 2019 from x.x.x.x     
      System: OK     
      Clusters:      
        RP_site1:      
          RPAs: OK     
          Volumes: OK     
          Splitters: OK     
      WANs: OK     
      Groups: OK      
     
      RP_site1> 
   
   
    NOTE: If both ping and SSH are not successful, please engage the Dell EMC RecoverPoint Support team for further assistance.   
   
   
    2. Once step 1 is successful, please follow the KB article listed below in order to import the   
        RecoverPoint certificates to the VPLEX cluster (Please perform the same step on both   
        VPLEX clusters in case of Metro configuration).       
    3. Once step 2 is successful, please follow the KB article listed below in order to remove the existing   
        RecoverPoint Appliances (RPAs) from VPLEX and then re-add the same RPA(s) to V{LEX   
        (Please perform the same step on both VPLEX clusters in case of Metro configuration).