XtremIO: Physical XMS running 6.2.2-3 (or later 6.2.2 versions) may experience management network configuration failure

           

   Article Number:     537137                                   Article Version: 8     Article Type:    Break Fix 
   

 


Product:

 

XtremIO Family

 

Issue:

 

 

   

      A Physical XMS running code version 6.2.2-3 (or later 6.2.2 versions) may experience management network failure configuration following the XMS upgrade.     
          

                                                             

 

 

Cause:

 

 

   

      XMS version 6.2.2-3 (or later 6.2.2 versions) introduced support for dual IPv4 and IPv6 which could cause management network issue within certain switch port configurations. Upon completion of the XMS upgrade on a Physical XMS, a network reset is issued and the network reset takes a certain period of time which can affect communication with the cluster. The prolonged network setup may result in a failure of the XMS Recovery process from the managed clusters, leaving the XMS unable to manage said clusters.    
                                                             

 

 

Resolution:

 

 

To prevent this issue, prior to XMS upgrade to version 6.2.2-3 (or later 6.2.2 versions), the portfast setting should be enabled on the customer's switch port connected to the physical XMS management port.   
    Enabling portfast on the switch port connected to XMS management interface allows the network to reset faster, thus allowing the XMS recovery to complete in a timely manner.   
    Please refer to the following Cisco Link for further information on how to check the portfast status on a port and how to configure it.     
     
      A permanent fix will be included in an XMS version subsequent to 6.2.2-x.