Symptoms
DPA is unable to email out scheduled reports.
Reviewing the Application server.log show the report was requested to run and sent successfully to report engine:
2018-02-20 17:59:52,883 INFO [com.emc.dpa.command.reporter.execution.ReportExecutionMDB] (Thread-12778 (HornetQ-client-global-threads-60137854)) Running Report for be6558a7-7304-4fd2-8690-889c57773778 - Custom Data Domain System Utilization
2018-02-20 17:59:52,884 INFO [com.emc.dpa.command.reporter.execution.RunReportFacadeBean] (Custom Engineering Backup Summary Control Panel:51931ef7-2a67-4e1f-bdb7-4037f2837f1c:Sched) Report Queued - be6558a7-7304-4fd2-8690-889c57773778 - Custom Data Domain System Utilization
2018-02-20 17:59:52,895 INFO [com.emc.dpa.command.reporter.execution.ReportExecutionMDB] (Thread-12762 (HornetQ-client-global-threads-60137854)) Sent Report to report engine 27af9b7a-770a-49d2-b900-d3a09bb54088 - Data Domain Utilization without publishing
The reportengine.log show that the report is created:
17:59:52,904 INFO [com.emc.dpa.reportengine.processor.ReportEngineMessageListener] (ReportEngineMessageListener #1:Data Domain Utilization:27af9b7a-770a-49d2-b900-d3a09bb54088) starting running report with identifier: 27af9b7a-770a-49d2-b900-d3a09bb54088
Hence DPA was able to successfully run and create a report but not sent out the report via email. When the publishment method is changed from email to file in the scheduled reports, the report was generated under services/shared/report-results/scheduled.
Cause
The Mail server was rejecting the DPA Application server SMTP requests.
Within the Mail server logs the rejection of the DPA Application server SMTP requests with "Relay access denied" is seen:
Resolution
Adjust the Mail server configuration to allow relaying will resolve the issue or have the DPA Application server use a different Mail server which allows relays.