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Article Number: 000167907


DPA Jobmonitor requests in 'Queued for Processing' state

Article Content


Symptoms



Several of the DPA Jobmonitor requests (for any Backup Application) are in a "Queued for Processing" state and do not change. 

Symptoms:
  • Incomplete Job Reports (e.g., missing clients)
  • Empty Reports which would result in scheduled reports not being published.
  • If alerting has been enabled, failure to get an alert of an event.


Cause

Although there are many scenarios on why requests are in a "Queued for Processing" state the most common reason is due to the DPA Servers being restarted without first stopping the DPA processes first.  This is commonly seen after an O/S level patch implementation.
Due to the incorrect restart procedure, it created an orphaned transaction which failed to close properly which causes a disruption to any future transactions leading to requests being in a "Queued for Processing" state.

Resolution

Run the following query against the DPA Datastore to verify if these orphaned transactions exist:

For WINDOWS:
  • dpa ds query "select * from pg_prepared_xacts;" > preparedxacts.txt
For UNIX:
  • ./dpa.sh ds query "select * from pg_prepared_xacts;" > preparedxacts.txt
If any prepared transaction do exist please contact Dell EMC Technical Support and provide the output file created from the above command.
They will be able to provide assistance on removing the orphaned transaction.

Article Properties


Affected Product

Data Protection Advisor

Product

Data Protection Advisor

Last Published Date

20 Nov 2020

Version

2

Article Type

Solution