"Command failed: Package lia-2.6-11000.113 for OS rhel7 is Not Signed"

           

   Article Number:     530753                                   Article Version: 2     Article Type:    Break Fix 
   

 


Product:

 

VxFlex OS

 

Issue:

 

 

While performing Upgrade from IM after the package has been uploaded , lia package install fails with bellow error message    
   
    Gateway Operations.log    
    2019-02-19 16:11:42,659 [scheduler-1] ERROR operations - Could not install lia with installationId 1fdd15f7443a7b8e, allowReboot false and arguments  on node 192.168.0.163 due to: Command failed: Package lia-2.6-11000.113 for OS rhel7 is Not Signed   
    2019-02-19 16:11:42,659 [scheduler-1] ERROR operations - Could not install lia with installationId 1fdd15f7443a7b8e, allowReboot false and arguments  on node 192.168.0.160,192.168.1.160 due to: Command failed: Package lia-2.6-11000.113 for OS rhel7 is Not Signed   
   
    Error Message during LIA package Install from Gateway
                                                           

 

 

Cause:

 

 

Per Upgrade process the Gateway needs to be upgraded to the target version first ( In this case the target version is 2.6.1.1)   
    Attempt to upgrade MDM,SDS and LIA components from Gateway prior to upgrading Gateway will result in package signature verification error as seen above.   
     
                                                           

 

 

Resolution:

 

 

Gateway needs to be upgraded first to the target version .   
    In this case the gateway version was 2.6.1 attempt to upgrade the other components to 2.6.1.1 will fail .   
    Upgrade gateway to target version 2.6.1.1 and then continue with the Upgrade process.