IDPA 4400 : 2.2.0-614446.x86_64 Pre-Patch Issues and workarounds

           

   Article Number:     534528                                   Article Version: 4     Article Type:    Break Fix 
   

 


Product:

 

Integrated Data Protection Appliance Family

 

Issue:

 

 

Below is the information about 4 issues that were discovered in the current IDPA 2.2 Pre-Patch(Build: 2.2.0-614446.x86_64)     
     
      Issue#1 : InfrastructureComponents.xml file gets updated with incorrect entries     
      Failure Noticed at :  11%     
      Logs information: /usr/local/dataprotection/var/configmgr/server_data/logs/server.log 
   

      019-06-03 15:31:32,822 INFO  [pool-5-thread-3]-dao.InfrastructureComponentsDAOImpl: getInfrastructureInfo Retrieving infrastructure components details from file /usr/local/dataprotection/var/configmgr/server_data/config/InfrastructureComponents.xml2019-06-03 15:31:32,824 INFO  [pool-5-thread-3]-dao.InfrastructureComponentsDAOImpl: getInfrastructureInfo Successfully retrieved infrastructure components details2019-06-03 15:31:32,824 ERROR [pool-5-thread-3]-idpavapp.ConfigIdpaVappTask: Exception occurred while executing Data Protection vApp Config task. Error message nullIssue #2 : 'Idpauser' user and 'idpa' role is created on ESXi Server but the login may not work with the common passwordFailure Noticed at : 97%Logs Information: Web UIInitial workflow might not have any error messages for idpauser creation on ESXi but Subsequent Retry may throw the below error message:FAILED: Failed to create ESX user idpauser.Error: Error occurred while creating ESX user idpauser.    
Issue #3 : 'Idpauser' user and 'idpa' role is created on vCenter Server but the login may not work with the common password     
      Failure Noticed at : 97%     
      Logs Information: /usr/local/dataprotection/var/configmgr/server_data/logs/server.log     
      Initial workflow might not have any error messages for idpauser creation on vCenter but Subsequent Retry may throw the below error message:
   
      ERROR [pool-121-thread-6]-vi.ViJavaAccess: createEsxUser Error creating user: idpauser    
.     
     
      Issue #4 : ESXi Root User password does not get set to 'common password' at the end of the configuration workflow     
      Failure Noticed at : 97%     
      Logs Information: Web UI
   
      FAILED: Failed to change ESXi password.Error: Unable to update ESXi root password 10.x.x.x    
                                                             

 

 

Cause:

 

 

Cause for Issue #1 : User Error (Pre-Patch is applied after the Network configuration)   
   
    Cause for Issue #2 : Software Bug   
   
    Cause for Issue #3 : Software Bug   
   
    Cause for Issue #4 : Software Bug
                                                           

 

 

Resolution:

 

 

   

      Workaround for Issue #1 : InfrastructureComponents.xml file gets updated with incorrect entries1) Make sure you are on the Welcome Page of the Configuration WizardUser-added image2) Login to ACM using root user via putty and stop the ACM webapp service using the 'service dataprotection_webapp stop' command3) Replace Infrastructurecomponents.xml file with the below contents under /usr/local/dataprotection/var/configmgr/server_data/config     
   
      <?xml version="1.0" encoding="UTF-8" standalone="yes"?><InfrastructureComponents>    <ACM>        <ipAddress>_enter_acm_public_ip </ipAddress>    </ACM>    <ESXiHosts>        <ESXi>            <ipAddress>_enter_esxi_public_ip </ipAddress>            <privateIpAddress>192.168.100.101</privateIpAddress>            <username>root</username>            <password isEncrypted="false">Idpa_1234</password>            <isIdpaUserCreated>false</isIdpaUserCreated>            <isRootPasswordChanged>false</isRootPasswordChanged>        </ESXi>    </ESXiHosts></InfrastructureComponents>    
   

      Edit the following parameters with correct values:       
        _enter_acm_public_ip with ACM Public IP Address
   

   

      _enter_esxi_public_ip with ESXi Public IP Address       
       
         4) Start the ACM webapp service using 'service dataprotection_webapp start'       
       
       
        Workaround for Issue #2 : 'Idpauser' user and 'idpa' role is created on ESXi Server but the login may not work with the common password       
        Follow KB IDPA 4400 : How to create idpauser and it's role on ESXi Server       
       
       
        Workaround for Issue #3 : 'Idpauser' user and 'idpa' role is created on vCenter Server but the login may not work with the common password       
        In order to workaround this issue, we need to do the following:       
        1) Verify if the idpauser and idpa role exists on vCenter       
        2) Delete the idpauser and idpa role on vCenter       
        3) Create the idpauser and idpa role with correct permissions on vCenter       
       
        Follow the below KB's in sequence       
        IDPA 4400 : How to verify 'idpauser' and 'idpa' role exists on vCenter         
          IDPA 4400 : How to delete 'idpauser' and 'idpa' role on vCenter
       
        IDPA 4400 :  How to create idpauser and it's role on vCenter       
       
       
        Workaround for Issue #4 : ESXi Root User password does not get set to 'common password' at the end of the configuration workflow       
        Follow KB IDPA 4400 : How to change ESXi root password and sync it with ACM