VxFlex - scini devices not discovered following a reboot

           

   Article Number:     533984                                   Article Version: 2     Article Type:    Break Fix 
   

 


Product:

 

VxFlex OS,VxFlex OS 2.6.1.1

 

Issue:

 

 

Scini devices were seen correctly by the OS prior to reboot.    
   
    Following a reboot the OS was unable to detect the scini devices, only local disks were visible.   
   
    Confirmed that lvm.conf is configured correctly          
   
    types = [ "scini", 16 ]   
    filter = [ "a|/dev/scini*|", "r/.*/" ]   
   
    Running "systemctl start lvm2-lvmetad.service" enabled the OS to discover the scini devices
                                                           

 

 

Cause:

 

 

lvmetad was enabled in etc/lvm/lvm.conf                                                           

 

 

Resolution:

 

 

Fix:   
    Disabling lvmetad in lvm.conf enabled scini devices to be discovered following a reboot.   
   
    1) Stop the lvmetad daemon:   
   
    sudo systemctl stop lvm2-lvmetad   
   
    2) Edit /etc/lvm/lvm.conf and set use_lvmetad to 0:   
   
    use_lvmetad = 0   
   
    3) Restart the lvmetad daemon:   
   
    sudo systemctl start lvm2-lvmetad