Symptoms
No Change in the environment.
AppSync server log is not rotating as configured in the AppSync server settings. One Server logs continuously grows.
The AppSync Server log is named server.log and found in <Install Dir>\AppSync\jboss\logs.
Cause
AppSync fails to rename the last server.log file to server.log.1 and continues to use the same file which grows in size, due to a software bug.
Resolution
There are three possible separate Workarounds:
- Restart the EMC AppSync Server Services manually.
Note: Make sure no service plan or activity is running on the AppSync server while restarting the service.
- Run the below REST command using REST client. You can get it from the Add Ons section > Get Add Ons of Mozilla firefox:.
- Request, PUT:- https://XXXX:8445/appsync/rest/instances/setting::traces.parameters.logsize
- Payload/Body: <setting name="traces.parameters.logsize" value="11m"/>
- Set Headers: Content-Type: application/atom+xml
- To avoid manual intervention:
Schedule a small bat file to automatically restart the AppSync Server Services at a time known to not have any AppSync protections running. The script can also backup existing server log files if desired. Also if desired, the script can check the size of the server log files to determine if a restart of the AppSync Services is needed.
A Permanent fix for log rotation issue is anticipated to be included in the Generally Available (GA) release of AppSync following version 3.7. Refer to the release notes for the version following AppSync 3.7 when GA for definitive information.