Data Domain: DD3300 Power Supplies are in Absent State

           

   Article Number:     531081                                   Article Version: 2     Article Type:    Break Fix 
   

 


Product:

 

DD3300 Appliance,Data Domain

 

Issue:

 

 

The Data Domain Operating System queries iDRAC (integrated Dell Remote Access Console) to determine the status of the power supplies, PSU 1 and PSU 2. When this communication is interrupted, the status of the PSUs cannot be reliably determined and will post an alert that both power supplies are absent. The system will remain in the same state until the condition is resolved.   
   
   
    Applies to:   
    DD3300 appliance only       
        DDOS version 6.1.x
   
     
                                                           

 

 

Cause:

 

 

Cause    
    The issue is caused by a bug in certain versions of the iDRAC module firmware. It fails to fully provide hardware information to DDOS. As a result, DDOS assumes this hardware is either missing or in a failed state.    
   
   
    Symptoms:   
    The PSU will have an OK status, however, the Part No. and the Serial No. will be missing.    

      Power Supply     
                          
      Description      Product ID     Part No.   Serial No.   Version  Status     
      --------------   ------------   --------   ----------   --------   ------     
      Power Supply 1   Power Supply                           00.1B.53   OK         
      Power Supply 2   Power Supply                           00.1B.53   OK         
      --------------   ------------   --------   ----------   --------   ------   
        
    Under normal conditions, the power supply status will look like the following:   
        
      Power Supply     
            
      Description      Product ID     Part No.    Serial No.       Version   Status     
      --------------   ------------   ---------   --------------   --------   -----     
      Power Supply 1   Power Supply   0PJMDNA01   PHARP0081601MA   00.1B.53   OK         
      Power Supply 2   Power Supply   0PJMDNA01   PHARP0081701D2   00.1B.53   OK         
      --------------   ------------   ---------   --------------   --------   -----   
        
        
        
    A “Power Supply is Absent” alert will be posted for both PSU1 and PSU2.   
        
      Alerts History     
      --------------     
      p0-15   Mon Jun 18 22:02:11 2018   (active)     CRITICAL   HardwareFailure   Enclosure=1:PowerSupply=1   EVT-ENVIRONMENT-00027: Power supply is absent     
      p0-16   Tue Jun 19 00:25:37 2018   (active)     CRITICAL   HardwareFailure   Enclosure=1:PowerSupply=2   EVT-ENVIRONMENT-00027: Power supply is absent     
          
This particular issue can be confirmed by observing the following log file:    
      /ddr/var/log/debug/messages.engineering   
If parsing related error messages from vulcanmon or SMS like the following are found, “Error parsing ________ info” we can reasonably assume that this particular issue is occurring:   
    Examples:    
      sms: INFO: Error parsing FAN list info     
      vulcanmon: INFO: Error parsing drives info     
      vulcanmon: INFO: Error parsing PSU info   
                                                             

 

 

Resolution:

 

 

                                             

Resolution           
                          
               Upgrade operating system:           
               This issue is fixed in DDOS 6.2.x. Please consider upgrading the OS to obtain a fix for this issue.                 
                                      
                     In the event that you currently experience this issue, please manually initiate a restart of iDRAC
           
               by following the below steps. iDRAC will require about 5 minutes to restart, and proper disk            
               monitoring will be restored. The alerts will clear automatically.
        
    Workaround.   
    The issue can typically be mitigated by resetting the system’s iDRAC module:    
         
  1.         Login to the system’s IDRAC GUI.      
  2.      
  3.         In the navigation bar, under the Maintenance dropdown menu, click Diagnostics.      
  4.      
  5.         Click Reset iDRAC.      
  6.      
  7.         User-added image     
  8.      
  9.         Wait 5 minutes for the iDRAC module to reset.     
  10.      
  11.         Confirm that the alerts are cleared.      
  12.