PowerPath: Unable to boot the system after setting a global_filter in /etc/lvm/lvm.conf[1]


   Article Number:     530151                                   Article Version: 3     Article Type:    Break Fix 




PowerPath for Linux





Unable to boot the system after setting a 'global_filter' in '/etc/lvm/lvm.conf' but able to boot the system if the 'global_filter' is commented out.   

The Error occurring during boot:Timed out waiting for device dev-mapper-rhel00\x2dhome.device.Dependency failed for /home.Dependency failed for Local File Systems.Dependency failed for Relabel all filesystems, if necessary.Dependency failed for Mark the need to relabel after reboot.Dependency failed for Migrate local SELinux policy changes from the old store structure to the new structure.    
    / and /home was not able to get mounted while the filter settings were ON in the lvm.conf file                                                           






The internal devices are under RAID control; since it is a local boot setup, the / and /home are created on the local disk and the SCSI disk representation for them is '/dev/md*'. There is no entry to accept '/dev/md*' in the global filter and hence causing the host to not accept the internal devices when the filter is applied in lvm.conf   
    The physical Volume looks like this:   
      — Physical volume —   
      PV Name               /dev/md126p3   
      VG Name               rhel00






Applying the global filter setting in lvm.conf file, causing the host  not to recognize the internal devices under RAID Configuration any more.   







      Modify the filter to accept all md* devices as below to be able discover the device and to mount / and /home as well when the server is booting:   


      global_filter = [ "a|/dev/./by-id/scsi-35001173101465378.|", "a|/dev/./by-id/scsi-0123456789abcdfc0.|", "a/md./",* "a/emcpower./", "r/sd./", "r/disk.*/" ]   







Identify the underlying Physical Volume names needed at boot time and add them to the lvm.conf file accordingly.