ViPR SRM 4.x: Unable to acknowledge, assign or close alerts (User Correctable)

           

   Article Number:     517030                                   Article Version: 5     Article Type:    Break Fix 
   

 


Product:

 

ViPR SRM

 

Issue:

 

 

Users may be unable to perform any actions on alerts that are shown in reports like All Alerts, Unacknowledged Alerts and others. Actions that do not work include 'Acknowledge', 'Assign', 'Force Close' and 'Take Ownership'.   
   
    When selecting any of the available actions, any of the following error messages may be shown briefly in the SRM GUI:   
        

          
   
      java.net.UnknownHostException: (FQDN)at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:184)at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)at java.net.Socket.connect(Socket.java:589)    
   
    OR:   
        
      java.net.NoRouteToHostException: No route to hostat java.net.PlainSocketImpl.socketConnect(Native Method)at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350)at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)at java.net.Socket.connect(Socket.java:589)    
   
    OR:   
          
   
      java.net.ConnectException: Connection refused (Connection refused)at java.net.PlainSocketImpl.socketConnect(Native Method)at java.net.AbstractPlainSocketImpl.doConnect(AbstractPlainSocketImpl.java:350)at java.net.AbstractPlainSocketImpl.connectToAddress(AbstractPlainSocketImpl.java:206)at java.net.AbstractPlainSocketImpl.connect(AbstractPlainSocketImpl.java:188)at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:392)at java.net.Socket.connect(Socket.java:589)    
                                                             

 

 

Cause:

 

 

Alert actions work by running scripts on the Frontend host. In some circumstances, a configuration file on the Frontend host may have an incorrect setting for the Primary Backend host and this prevents the scripts on the Frontend host from connecting to the Primary Backend host and perform the required actions on the event database.                                                           

 

 

Resolution:

 

 

Locate the following configuration file on the Frontend host:   
   
    Linux:   
    /opt/APG/Custom/WebApps-Resources/Default/actions/event-mgmt/linux/conf   
   
    Windows:   
    \Program Files\APG\Custom\WebApps-Resources\Default\actions\event-mgmt\windows\conf.cmd   
   
    Edit the following entry and ensure that it contains the correct IP address or FQDN of the Primary Backend host:   
   
    Linux:   
    PRIMARYBACKEND=<IP or FQDN>   
   
    Windows:   
    set PRIMARYBACKEND=<IP or FQDN>   
   
    Save the conf file and re-try the alert actions. No service restarts are necessary. The config file is read every time an action script is invoked.
                                                           

 

 

Notes: