RecoverPoint: Upgrade failed due to RPA not coming up - RPA console shows "error: file '/vmlinuz-upgrade' not found."

           

   Article Number:     534002                                   Article Version: 5     Article Type:    Break Fix 
   

 


Product:

 

RecoverPoint CL,RecoverPoint,RecoverPoint EX,RecoverPoint SE

 

Issue:

 

 

RecoverPoint upgrade fails due to RPA not coming up after ISO upgrade (Step 2/4 of DM).   
    RPA console shows error:   
    error: file '/vmlinuz-upgrade' not found.   
    alloc magic is broken ax 0xXXXXXXXX" XXXXXXXX   
    Aborted. Press any key to exit.   
   
   
   
    Symptom found in the log:   
    Deployment log:    

      ...   
        
          
   
      RPA file system usage prior to upgrade (df -h):   
   
      Filesystem      Size  Used Avail Use% Mounted on       
        rootfs          969M  966M     0 100% /       
        /dev/root       969M  966M     0 100% /       
        tmpfs           3.2G  312K  3.2G   1% /run       
        tmpfs           5.0M     0  5.0M   0% /run/lock       
        tmpfs            10M     0   10M   0% /dev       
        tmpfs            16G     0   16G   0% /dev/shm       
        /dev/md2        1.1T   42G  994G   4% /home       
        /dev/md3        969M   18M  902M   2% /tmp       
        /dev/md6        969M  774M  145M  85% /usr       
        /dev/md5        969M  359M  560M  40% /var       
        none             16G     0   16G   0% /dev/shm
   
                                                             

 

 

Cause:

 

 

Due to the accumulation of files in /root directory of an RPA, an ISO upgrade may fail because of shortage of space.   
    The RPA reboots to boot from the upgrade file, but since / was full, the link is missing and it cannot boot from it.
                                                           

 

 

Change:

 

 

RPA cluster upgrade                                                           

 

 

Resolution:

 

 

Workaround:   

      A solution exists for this issue but intervention from EMC technical support personnel is required. Root access is required to fix the issue.Contact the EMC Customer Support Center or your service representative for technical assistance and quote this solution ID.   

   

     
      To check the RPA Filesystem usage, the follow script can be run:     
     
      Login as boxmgmt via putty/ssh -> [2] Setup -> [8] Advanced options -> [4] Run script   

   

      MWRkYzUzODdmM2FkYTY2OGJlYjM3OTc1ZTdlZmY5ZGYKdW5saW1pdGVkCm5vdF9yZXN0cmljdGVk       
        ClRoZSBpZCBvZiB0aGUgc2NyaXB0IGlzOjUzNDAwMgpkZiAtawpOaXYgTmV0YW5lbGkKIyEvYmlu       
        L3NoCmRmIC1oCmV4aXQgMAo=       
        #
     
          

   

      A script that cleans up files normally taking up space:   

   

      MDI2NDc5MDc1YTM1NTRmYzIzMzRkMmZhZWMwNGQ4NjgKdW5saW1pdGVkCm5vdF9yZXN0cmljdGVk       
        ClRoZSBpZCBvZiB0aGUgc2NyaXB0IGlzOgpDbGVhbnMgYWxsIGtub3duIGZ1bGwgZmlsZSBzeXN0       
        ZW0gZmlsZXMKQXNzaWYgSGFsCi9ldGMvaW5pdC5kL3JzeXNsb2cgcmVzdGFydDtlY2hvICIiID4v       
        cm9vdC9kZWFkLmxldHRlcjtlY2hvICIiID4vb3B0L2RlbGwvc3J2YWRtaW4vdmFyL2xvZy9vcGVu       
        bWFuYWdlL2RldmljZWFkZC5ldnQ7ZWNobyAiIiA+L3Zhci9sb2cvbWVzc2FnZXM7ZWNobyAiIiA+       
        L3Zhci9sb2cvYXV0aDtlY2hvICIiID4vdmFyL2xvZy9tYWlsLmVycjtlY2hvICIiID4vdmFyL2xv       
        Zy9tYWlsLmluZm87ZWNobyAiIiA+L3Zhci9sb2cvbWFpbC5sb2c7ZWNobyAiIiA+L3Zhci9sb2cv       
        bWFpbC53YXJuCg==       
        #