After migrating DPA servers from 6.2.3 to 6.5.0, the agent failed to register with the Application server.[1]

           

   Article Number:     521147                                   Article Version: 3     Article Type:    Break Fix 
   

 


Product:

 

Data Protection Advisor 6.5

 

Issue:

 

 

DPA servers were migrated from 6.2.3 to 6.5.0.  After the migration, the agent failed to register with the Application server.  In the Agent logs the following error is seen:   
   
    dpaagent log:   

      WARN    16719.16749    20180503:151706      com.agent.lstnr - cSendToListener(): Error sending results to https://127.0.0.1:9002/dpa-api/agent/73f34c9e-62f9-43db-b481-c3eb60e62716/report because the server rejected the request:   

WARN    16719.16749    20180503:151706      com.agent.lstnr - cSendToListener(): Error sending results to https://127.0.0.1:9002/dpa-api/agent/73f34c9e-62f9-43db-b481-c3eb60e62716/report because the server rejected the request:     
      WARN    16719.16749    20180503:151706      com.agent.lstnr - cSendToListener(): Error sending results to https://127.0.0.1:9002/dpa-api/agent/73f34c9e-62f9-43db-b481-c3eb60e62716/report because the server rejected the request:
   
                                                                

 

 

Cause:

 

 

During the creation of the new DPA 6.5.0 server the Agent password was set on the Application server but the existing Agents where not updated with this new password.                                                           

 

 

Resolution:

 

 

1.  To set the Agent password run the following command on the Agent host:   
    dpaagent --set-credentials   
    The password should match the Agent password as set on the DPA Application server   
    2.  Restart the Agent   
    3.  The Agent should now successfully register with the DPA Application server