Data Protection Advisor (DPA): Upgrade fails Reason: There are active connections to datastore

           

   Article Number:     528907                                   Article Version: 3     Article Type:    Break Fix 
   

 


Product:

 

Data Protection Advisor,Data Protection Advisor Family

 

Issue:

 

 

When running the DPA Server upgrade binaries on the DPA Datastore server the following pop error message is seen:     

          
   
      Please contact support and provide the install logs to help with the upgrade.     
      Reason: There are active connections to datastore.     
      PRESS <ENTER> TO ACCEPT THE FOLLOWING (EXIT):     
     
      The DPA Application Server was stopped before the upgrade attempt and no Installation log was created.  Additionally nothing meaningful or related is logged in any DPA Datastore logs.    
                                                             

 

 

Cause:

 

 

Root cause was not positively identified. Suspect a transaction or connection to the DPA Datastore Server was not correctly terminated when the DPA Application Server was stopped.                                                            

 

 

Resolution:

 

 

Workaround   
    1. Restart the DPA Datastore service   
    2. Verify there is no activity in the DPA Datastore database   
    3. Once confirmed there the DPA Datastore is quite attempt the installation again   

      Please contact Dell EMC Technical Support for further details or information.