RecoverPoint: Removing primary copy causes all RPAs to crash

           

   Article Number:     529848                                   Article Version: 4     Article Type:    Break Fix 
   

 


Product:

 

RecoverPoint CL 5.1 P1,RecoverPoint CL 5.1 SP2,RecoverPoint CL,RecoverPoint EX,RecoverPoint EX 5.1 P1,RecoverPoint EX 5.1 SP2,RecoverPoint SE,RecoverPoint SE 5.1 P1,RecoverPoint SE 5.1 SP2,RecoverPoint

 

Issue:

 

 

Symptoms found in the control logs:   

      Log collector entry(2426-1): HOST-VOLUMES FirstStep.          
          ...          
          Log collector entry(2426-1): Not performing HM_bigAction - actual data is empty.          
          ...          
          Log collector entry(2426-1): isTaskOpen: false Reason=Group disabled by user          
          ...          
          Log collector entry(2426-1): cannot dirtify SBR link - no primary copy 
   

   

      2019/01/10 21:40:08.010 - #2 - 26218/25765 - StateChange: group: GroupCopy(1391717xxx SiteUID(0x705e77d41168xxxx) 0). perLastRTStates. primaryCopySet. (removed)    

   

      2019/01/10 21:41:47.669 - #2 - 18427/18285 - AssertLCPrinter: finished dumping LC          
          2019/01/10 21:41:47.669 - #0 - 18427/18285 - : errno=95 Assertion failed: relevant Line 53 File /home/builderv/ReleaseBuilds/rel-pyro/src/global_infra/ROption.hh PID: 18285 Info: 
   

                                                             

 

 

Cause:

 

 

RPA expects Primary Copy to always be present.   
    When it was removed, the data structure which stores the ID of this copy was set to NULL, which when de-referenced, caused the de-reference assertion failure. 
                                                           

 

 

Change:

 

 

Removing Primary Copy                                                           

 

 

Resolution:

 

 

Workaround:   
   
    Remove problematic groups from the working clusters and re-attach the RPAs again. After removing those problematic groups, the settings will synchronize and the system should stabilize.    
   
    Resolution:   
   
    Dell EMC engineering is currently investigating this issue. A permanent fix is still in progress. Contact the Dell EMC Customer Support Center or your service representative for assistance and reference this solution ID.