Data Protection Advisor DPA Avamar Job monitor collection request times out[2]

           

   Article Number:     517621                                   Article Version: 4     Article Type:    Break Fix 
   

 


Product:

 

Data Protection Advisor

 

Issue:

 

 

Data Protection Advisor DPA Avamar Job monitor collection request times out on large busy Avamar grids.  The agent timeout has been increased to 12 hours within the dpaagent_config.xml but this does not assist.   
     
                                                           

 

 

Cause:

 

 

Reviewing the dpaagent.logs it was determined that replication SQL queries to the Avamar MCS where taking a long time to complete.  In current versions of Avamar most of the replication tables do not remove historical information which can lead to them being very large on busy long running systems.  To confirm if this is the occurring the following queries can run on the Avamar MCS:   
    psql -p 5555 mcdb -c "select count ( * ) FROM v_repl_backups;"   
   
    If the above query takes a long time to return and the value return is high this would indicate there may be a large amount of historical information in the repl_backups table.     
    psql -p 5555 mcdb -c "select relname, relpages from pg_class order by relpages desc limit 20;"   
   
    The above query provides some information on the size of the tables within the Avamar MCS.  If the repl_backups table is one of the larger ones this again would indicate there may be a large amount of historical information within this table.   
   
    If either of these queries indicate there is a large amount of historical information in the repl_backups table, please open a new SR with Avamar Support so they can investigate and see if it is possible to reduce the size of this table.  Provide the output of the two queries along with all the troubleshooting details collected to Avamar Support.   
   
     
                                                           

 

 

Resolution:

 

 

Determined DPA working as designed. The problem was that Avamar was taking too long to process queries run. We opened and reviewed the problem with Avamar support who worked to reduce the size of tables. This allowed queries to return more quickly.