VxRail: VxRail and external vCenter interoperability matrix

           

   Article Number:     520355                                   Article Version: 29     Article Type:    How To 
   

 


Product:

 

VxRail Software,VxRail Appliance Series,VxRail Appliance Family

 

Instructions:

 

 

   

      This article details appropriate external vCenter versions for use with VxRail.     
      To see specific VxRail versions and each component code levels refer to the: VxRail Support Matrix     
     
      VxRail upgrade paths can be found in the Upgrade Paths section in the VxRail Release notes. These can be found at:   

       

     
      VxRail upgrades and External vCenter     
     
      When upgrading VxRail to a later build you need to ensure that your external vCenter build is already at the minimum version required for the VxRail build you are planning to upgrade to.     
      It is a requirement to upgrade your external vCenter before upgrading the version of VxRail.     
      Note: This is the only scenario that the minimum and maximum versions are relaxed but this is only during the upgrade of the cluster.     
     
     
      Support for external vCenter 6.7 and VxRail 4.0.x/4.5.x releases     
     
      Support for vCenter 6.7 U1 and later has been added to the following VxRail releases but with specific upgrade requirements:   

   
         
  •                 

              VxRail 4.0.520 and later       

                  
  •      
  •                 

              VxRail 4.5.215 and later       

                  
  •    
   

      Note: Due to changes in the vCenter APIs in 6.7 you must upgrade VxRail 4.0 or 4.5 to one of the supported releases before you upgrade vCenter to 6.7 U1.     
      It is not supported to upgrade external vCenter to 6.7 before you upgrade VxRail to a supported version.     
      Thus before you upgrade your external vCenter to 6.7 U1 or later you need to have VxRail at a minimum using versions VxRail 4.0.520 / VxRail 4.5.215 or later.     
     
      For more information on VxRail upgrade paths see the VxRail Appliance software 4.5.x upgrade paths section in the VxRail Appliance 4.5.x Release notes     
     
     
      Matrix of supported external vCenter versions with VxRail     
          

                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                                               
              

              VxRail Release            

              
              

              ESXi (Version - Build #)           

              
              

              External vCSA versions           

              
              

                          

              
              

              Min           

              
              

              Recommended           

              
              

              3.0           

              
              

              6.0 U1b - 3380124           

              
              

              N/A           

              
              

              N/A           

              
              

              3.5           

              
              

              6.0 U2 - 3620759           

              
              

              6.0 U2           

              
              

              6.0 U2 or later           

              
              

              4.0           

              
              

              6.0 U2 P03 - 4192238           

              
              

              6.0 U2           

              
              

              6.0 U2 or later           

              
              

              4.0.00001           

              
              

              6.0 U2 P04 - 4600944           

              
              

              6.0 U2           

              
              

              6.0 U2a or later           

              
              

              4.0.100           

              
              

              6.0 U2 P04 - 4600944           

              
              

              6.0 U2           

              
              

              6.0 U2a or later           

              
              

              4.0.132           

              
              

              6.0 U3 - 5050593           

              
              

              6.0 U2           

              
              

              6.0 U3 or later           

              
              

              4.0.200           

              
              

              6.0 EP07a - 5224934           

              
              

              6.0 U2           

              
              

              6.0 U3 or later           

              
              

              4.0.300           

              
              

              6.0 P5 - 5572656           

              
              

              6.0 U3           

              
              

              6.0 U3b or later           

              
              

              4.0.301           

              
              

              6.0 P5 - 5572656           

              
              

              6.0 U3           

              
              

              6.0 U3b or later           

              
              

              4.0.302           

              
              

              6.0 EP11 - 6765062           

              
              

              6.0 U3           

              
              

              6.0 U3b or later           

              
              

              4.0.310           

              
              

              6.0 P5 - 5572656           

              
              

              6.0 U3           

              
              

              6.0 U3b / 6.5 U1 or later           

              
              

              4.0.400           

              
              

              6.0 P6 - 6921384           

              
              

              6.0 U3           

              
              

              6.0 U3c / 6.5 U1 or later           

              
              

              4.0.401           

              
              

              6.0 P6 - 6921384           

              
              

              6.0 U3           

              
              

              6.0 U3d / 6.5 U1e or later           

              
              

              4.0.402**           

              
              

              6.0 EP13 - 7967664           

              
              

              6.0 U3e / 6.5 U1g           

              
              

              6.0 U3e / 6.5 U1g or later           

              
              

              4.0.500****           

              
              

              6.0 EP14 - 8934903           

              
              

              6.0 U3f / 6.5 U2b           

              
              

              6.0 U3f / 6.5 U2b or later           

              
              

              4.0.510           

              
              

              6.0 P07 - 9239799           

              
              

              6.0 U3g           

              
              

              6.0 U3g or later           

              
              

              4.0.520*****           

              
              

              6.0 EP15 - 9313334           

              
              

              6.0 U3h / 6.7 U1           

              
              

              6.0 U3h or later / 6.7 U1 or later           

              
              

              4.0.521*******           

              
              

              6.0 EP18 - 10474991           

              
              

              6.0 U3h / 6.7 U1           

              
              

              6.0 U3h or later / 6.7 U1 or later           

              
              

              4.0.522*           

              
              

              6.0 EP19 - 10719132           

              
              

              6.0 U3h / 6.7 U1           

              
              

              6.0 U3h or later / 6.7 U1 or later           

              
              

              4.5           

              
              

              6.5 U1 - 5969303           

              
              

              6.5 U1           

              
              

              6.5 U1 or later           

              
              

              4.5.070           

              
              

              6.5 EP04 - 6765664           

              
              

              6.5 U1           

              
              

              6.5 U1a or later           

              
              

              4.5.150           

              
              

              6.5 P2 - 7388607           

              
              

              6.5 U1           

              
              

              6.5 U1a or later           

              
              

              4.5.152**           

              
              

              6.5 EP06 - 7967591           

              
              

              6.5 U1g           

              
              

              6.5 U1g or later           

              
              

              4.5.200***           

              
              

              6.5 P2 - 7388607           

              
              

              6.5 U1           

              
              

              6.5 U1a or later           

              
              

              4.5.210**           

              
              

              6.5 U2 - 8294253           

              
              

              6.5 U2           

              
              

              6.5 U2 or later           

              
              

              4.5.211           

              
              

              6.5 U2 - 8294253           

              
              

              6.5 U2           

              
              

              6.5 U2 or later           

              
              

              4.5.212****           

              
              

              6.5 EP07 - 8935087           

              
              

              6.5 U2b           

              
              

              6.5 U2b or later           

              
              

              4.5.215           

              
              

              6.5 EP07 - 8935087           

              
              

              6.5 U2b / 6.7 U1           

              
              

              6.5 U2b or later / 6.7 U1 or later           

              
              

              4.5.218*****           

              
              

              6.5 U2C - 9298722           

              
              

              6.5.U2c / 6.7 U1           

              
              

              6.5.U2c or later / 6.7 U1 or later           

              
              

              4.5.225******           

              
              

              6.5 EP9 - 10175896           

              
              

              6.5.U2c / 6.7 U1           

              
              

              6.5.U2c or later / 6.7 U1 or later           

              
              

              4.5.227*******           

              
              

              6.5 EP10 - 10390116           

              
              

              6.5.U2c / 6.7 U1           

              
              

              6.5.U2c or later / 6.7 U1 or later           

              
              

              4.5.229*           

              
              

              6.5 EP11 - 10719125           

              
              

              6.5.U2c / 6.7 U1           

              
              

              6.5.U2c or later / 6.7 U1 or later           

              
4.5.300**6.5 P03 - 108849256.5 U2c / 6.7 U16.5 U2c or later / 6.7 U1 or later
              

              4.7.000           

              
              

              6.7 EP5 - 10764712            

              
              

              6.7 U1           

              
              

              6.7 U1 or later           

              
4.7.0016.7 EP5 - 10764712 6.7 U16.7 U1 or later
4.7.1006.7 EP6 - 116750236.7 U16.7 U1 or later
   
         
  •                 

              For 3.5, the version of VxRail manager after an data-in-place upgrade from 3.0 to 3.5 is 3.5.0-3992530. If the appliance as configured using MBS the VxRail manager version will be 3.5.0.3936871       

                  
  •      
  •                 

              For appliances with external vCenter, the minimum vCenter version starting on VxRail 3.5 is 6.0 U2 and vCenter on version 6.5 is not supported under VxRail 4.0.30x. This information is important for appliances using external vCenter as vCenter is not upgraded as part of the regular upgrade process. The recommendation is to keep the nodes / vCenter VMs aligned according to the table above, and upgrade of vCenter components may be needed if any issues are encountered, especially with vSAN health UI.       

                  
  •      
  •                 

              ** Spectre/Meltdown patches require later minimum vCenter version due to functionality dependencies created as part of the resolution of those security issues.       

                  
  •      
  •                 

              *** 4.5.200 is a factory only release (new nodes ordered from Dell/EMC will ship with this version) and is not available for regular customer upgrades. VxRail Appliance software 4.5.152 is the recommended version for VxRail 4.5.x customers who want to upgrade.       

                  
  •      
  •                 

              **** Speculative Store Bypass patches (VMSA-2018-0012) require later minimum vCenter version to ensure you are adequately protected against this security issue. See VMware KB: 55111 for more information.       

                  
  •      
  •                 

              ***** L1 Terminal Fault - VMM (VMSA-2018-0020) require later minimum vCenter version to ensure you are adequately protected against this security issue. See VMware KB: 55806 for more information.       

                  
  •      
  •                 

              ****** Fix for a potential in-guest data consistency issue that may be experienced by VxRail 4.5.x systems following a disk extend operation. See Dell EMC Technical Advisory  DTA 525859: VxRail: Virtual Machines (VM) running VxRail 4.5.x may report in-guest data consistency issues following a disk extend operation, which may result in potential data integrity issues for more information       

                  
  •      
  •                 

              ******* Fix for vSAN disk group with deduplication enabled might be marked as in permanent disk error with disk reporting out of space, even though the group has free blocks. See VMware 6.5 EP10 Release Notes for more information.       

                  
  •      
  •                 

              vmxnet3 uninitialized stack memory usage (VMSA-2018-0027). See VMSA-2018-0027 article for more information.       

                  
  •      
  •         ** Note vCenter 6.5u2d was released after 6.7u1 hence there is no direct upgrade from VxRail 4.5.300 to 4.7 at this time. For more information see Under the Hood – vSphere 6.7 Update 1     
  •      
  •         For appliances with internal vCenter all components are upgraded automatically during the regular upgrade process.     
  •    
   

      To cross reference vCenter versions with build numbers see VMware KB: Build numbers and versions of VMware vCenter Server (2143838)