EMC Storage Analytics 3.5. VMAX-1 not displaying Top-N

           

   Article Number:     487982                                   Article Version: 3     Article Type:    Break Fix 
   

 


Product:

 

Storage Analytics,Storage Analytics SW for VMAX

 

Issue:

 

 

After having upgraded the ESA to version 3.5, the VMAX Top-N stops reporting in the dashboards. Cannot upgrade past 3.5 as the VMAX-1 is not supported past ESA 3.5                                                           

 

 

Cause:

 

 

Top- N depend on the connection to SMI-S;  there's no response after ESA sent the collect request to smi-s , so that ESA skipped the collect cycle.   
   
    Setting the VMAX to debug level will display the following error messages   
   
    016-08-04 16:21:21.843 [INFO] [Collector worker thread 20] com.emc.pie.adapters.smis.symm.SymmPartition - Getting time last sampled from smi-s   
    2016-08-04 16:21:21.843 [DEBUG] [CimXferService-Thread-0] com.emc.pie.adapters.smis.xfer.CimXferServiceImpl - BEGIN xfer 646907 [10.252.2.131]   
    2016-08-04 16:21:21.843 [DEBUG] [CimXferService-Thread-0] com.emc.pie.adapters.smis.xfer.CimXferServiceImpl - path obj:http://10.X.X.X:5988/root/emc:Symm_StorageSystem.CreationClassName="Symm_StorageSystem",Name="SYMMETRIX-+-00019260xxxx"   
    2016-08-04 16:21:21.843 [DEBUG] [CimXferService-Thread-0] com.emc.pie.adapters.smis.xfer.CimXferServiceImpl - associationClass: cim_hostedcollection   
    2016-08-04 16:21:21.843 [DEBUG] [CimXferService-Thread-0] com.emc.pie.adapters.smis.xfer.CimXferServiceImpl - resultClass: cim_querystatisticscollection   
    2016-08-04 16:21:21.843 [DEBUG] [CimXferService-Thread-0] com.emc.pie.adapters.smis.xfer.CimXferServiceImpl - role: null   
    2016-08-04 16:21:21.843 [DEBUG] [CimXferService-Thread-0] com.emc.pie.adapters.smis.xfer.CimXferServiceImpl - resultRole   
    2016-08-04 16:21:21.847 [DEBUG] [CimXferService-Thread-0] com.emc.pie.adapters.smis.xfer.CimXferServiceImpl - END xfer 646907 in 0 secs [10.252.2.131]   
    2016-08-04 16:21:21.847 [INFO] [Collector worker thread 20] com.emc.pie.adapters.smis.symm.SymmPartition - Finished getting time last sampled from smi-s   
    2016-08-04 16:21:21.848 [INFO] [Collector worker thread 20] com.emc.pie.adapters.smis.symm.SymmPartition - Found time last sampled from smi-s: 20160804161100.822000-420   
    2016-08-04 16:21:21.848 [DEBUG] [Collector worker thread 20]com.emc.pie.commons.datetime.CimDateTimeParser - parsed cimDateTimeAbsolute=20160804161100.822000-420 into dtPart=20160804161100.822000, plusMinusPart=-, tzMinsPart=420   
    2016-08-04 16:21:21.848 [DEBUG] [Collector worker thread 20]com.emc.pie.commons.datetime.CimDateTimeParser - dt=2016-08-04T16:11:00.822-07:00   
    2016-08-04 16:21:21.848 [DEBUG] [Collector worker thread 20]com.emc.pie.commons.datetime.CimDateTimeParser - tzHours=7   
    2016-08-04 16:21:21.848 [DEBUG] [Collector worker thread 20]com.emc.pie.commons.datetime.CimDateTimeParser - dt=2016-08-04T16:11:00.822-07:00   
    2016-08-04 16:21:21.848 [DEBUG] [Collector worker thread 20]com.emc.pie.commons.datetime.CimDateTimeParser - parsed epoch[1470352260822,utc=Thursday, August 4, 2016 11:11:00 PM +00:00] from cimDateTimeAbsolute='20160804161100.822000-420'
                                                           

 

 

Resolution:

 

 

Since SMI-S is part of solutions enabler, determine the host where solutions enabler is installed. Run testsmiprovider to verify the array is being seen. Then if this is a Windows host, search for the ECOM process. If the ecom process is running, restart it.   

      On Windows you can restart the EMC SMI-S Provider using the Services wizard to restart the ECOM service, or you can perform the following steps in the CMD shell:   

   

      1.Stop the provider using following commands.   

   

      From the ECIM/ECOM/bin directory:   

   

      sm_service stop ecom.exe   

   

      From the ECIM/Slp/lib directory:   

   

      slpd -stop   

   

      2.Restart the provider using the following commands.   

   

      From the ECIM/ECOM/bin directory:   

   

      sm_service start ecom.exe   

   

      From the ECIM/Slp/lib directory:   

   

      slpd –start   

    After an hour the Top-N data should now be seen again