Networker backup fails with error: No connection could be made because the target machine actively refused it.

           

   Article Number:     490210                                   Article Version: 2     Article Type:    Break Fix 
   

 


Product:

 

NetWorker

 

Issue:

 

 

Environment:   
    NetWorker clients and NMM  8.2.2.6 B985   
    Exchange 2010 DAG with 3 nodes   
    Windows 2008 R2 6.1   
   
    After NetWorker upgrade customer cannot backup DAG Exchange.   
   
    DAG Exchange backups fails with errors:   
    97512:savefs: Cannot access NetWorker server 'nwserver.dom.local': Remote system error - No connection could be made because the target machine actively refused it.     
      savefs DAG1.dom.local: failed.
   
    or   
    95937:nsrsnap_vss_save:A slave job failure has been identified, stopping all slave jobsnsrsnap_vss_save: Exchange federated ..Updated saveset response with hresult 0x54f.     
      Internal error.     
      102333 1475244759 3 0 0 16748 17504 0 nwserver.dom.local nsrsnap_vss_save NSR error 21 Exiting with failure. 0.
   
   
    config checker on all nodes run without any errors   
    nsrsnap_vss_save -v -? on all nodes was able to list savesets   
   
    Communication from all physical nodes to server and vice versa were checked and looked good.   
    rpcinfo -p nwserver.dom.local     
      nslookup "client name"     
      nslookup "IP address" {Reverse Lookup}     
      nsradmin -s nwserver.dom.local -p 390113
   
   
    Telnet to 111 port from all physical nodes fails   
    telnet DAG1.dom.local 111   
    Connecting To DAG1.dom.local...Could not open connection to the host, on port 111: Connect failed   
   
    From client:   
    tracert or traceroute "Backup server name"   
    From Backup Server:   
    tracert or traceroute "Client name"   
     
                                                           

 

 

Cause:

 

 

When tracert was ran from the NW Server to Exchange it said IP was 10.66.9.177 as listed in the hosts file.   
    The routing table on the Exchange server shows that traffic being sent to the NW Server (10.66.9.124, which is IP in the 10.66.9.0/255.255.255.128 subnet) is being sent out the 10.66.9.77 interface on the Exchange server. So any response back to the NW Server from an Exchange node is passed along the 9.77 interface.   
    NW Server couldn't communicate via RPC to that IP address.   
    The problem was in routing table entry.
                                                           

 

 

Change:

 

 

Networker server upgrade                                                           

 

 

Resolution:

 

 

Add a static route that sent all traffic to the NW Server through the proper interface (10.66.9.177 interface in this particular case).