SourceOne Email Management -  Historical Archive/Shortcut jobs are failing due to SourceOne Service Account exceeding the maximum number of allowed sessions on Microsoft Exchange 2013 or above

           

   Article Number:     516910                                   Article Version: 6     Article Type:    Break Fix 
   

 


Product:

 

SourceOne,SourceOne Archiving,SourceOne Email Management

 

Issue:

 

 

EMC SourceOne Historical Archive/Shortcut jobs have higher failure rates. Error messages similar to the following are found in job detailed logs:   
        

      Failed to log on to mail source: UserDisplay Name (/o=<Org name>/ou=Org Unit name>/cn=Recipients/cn=<common name with exchangeSID>)    
   
    The SourceOne service account however is able to open user mailbox without issue which confirms that service account has permissions needed on the user mailbox. The same mailbox if processed in a individual archive or shortcut job, processes without any issue.   
   
    Events similar to the following can be found in the application event log on Microsoft Exchange mailbox server where SourceOne service account's mailbox is located.   
      Log Name:      ApplicationSource:        MSExchangeISDate:         3/14/2017 11:20:43 AMEvent ID:     9646Task Category: MAPILevel:         ErrorKeywords:      ClassicUser:          N/AComputer:      ExchangeServerDescription:Mapi session /o=<Org name>/ou=Org Unit name>/cn=Recipients/cn=<common name with exchangeSID> with client type MoMT exceeded the maximum of 32 objects of type Session.    
   
   
   
                                                                

 

 

Cause:

 

 

By default the maximum number of open sessions for any user on Microsoft Exchange Server is 32. When this limit is breached the Microsoft Exchange Server may stop the connections because SourceOne may be performing multiple operations (e.g. Journal, archive, shortcut activities, shortcut resolution and search restore to mailbox) from different servers at same time, it may lead to service account reaching this limit.                                                            

 

 

Resolution:

 

 

In case of Microsoft Exchange 2010 or below Please refer DELL EMC SourceOne support article mentioned below:   
    454545 : EMC SourceOne Historical Archive Activities are failing due to SourceOne Service Account exceeding the maximum number of allowed sessions on Microsoft Exchange https://support.emc.com/kb/454545   
   
    ------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------   
   
    If Microsoft Exchange 2013 or above is used then it is advised to upgrade to SourceOne Email Management version 7.2.6.6201 (7.2.6 + Hot Fix Bundle 3)   
    *** Please note that when installing Hot Fix Bundles (HFBs) they must all be installed and in the correct order for ALL fixes to be correctly applied.   
   
    The code change for the above version requires 3 mailbox permissions "Receive-as", "ms-Exch-Store-Visible" and "ms-Exch-Store-admin” for SourceOne service account.    
   
    Following is example of Exchange Management Shell command to set permissions on Microsoft Exchange at mailbox database level:    

Get-MailboxDatabase | Add-ADPermission -User "<SourceOne Service Account>" -AccessRights ExtendedRight -ExtendedRights Receive-As, ms-Exch-Store-Admin, ms-Exch-Store-Visible    
    Where <SourceOne Service Account> is your SourceOne Service Account.   
   
    The permissions can be checked using the following Exchange Management Shall command:   
    Get-MailboxDatabase -Identity "<MailBoxDatabase>"| Get-ADPermission -User SOne_Service |fl Identity,user,extendedrights   
   
    Where <MailBoxDatabase> is the name(s) of your Mailbox Databases.   
        
    Microsoft Exchange 2013 documents that service account should be passing admin flags while performing operations as service account to make sure those operations are not counted towards the defined limits for user mailboxes. Following is the blog post from MSDN which explains it: https://blogs.msdn.microsoft.com/dvespa/2014/01/06/9646-still-seen-on-exchange-2013-even-after-applying-view-information-store-status/   
   
    ------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------   
   
    Although the code fix alleviates many of the exchange limits if a large number of jobs are running at the same time then limits on Microsoft Exchange Servers will also have to be increased following Microsoft Article https://technet.microsoft.com/en-us/library/mt741981(v=exchg.150).aspx and Dell EMC SourceOne Article https://support.emc.com/kb/454545    
   
    Following are steps to increase session limit on each Microsoft Exchange Server:   
    NOTE: As per the Microsoft warning. Incorrectly editing the registry can cause serious problems that may require you to reinstall your operating system. Problems resulting from editing the registry incorrectly may not be able to be resolved. Before editing the registry, back up any valuable data.   
        
         
  1.         On the Microsoft Exchange Mailbox Server exhibiting the error, open the Registry Editor.     
  2.      
  3.         Go to HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\MSExchangeIS\ParametersSystem     
  4.      
  5.         Right-click ParametersSystem, point to New, and then click DWORD (32-bit) Value.     
  6.      
  7.         Type “Maximum Allowed Sessions Per User” as the key name     
  8.      
  9.         In the Value data box, type the number of objects to limit this entry to (e.g. 200 decimal), and then click OK.     
  10.      
  11.         Close Registry editor     
  12.      
  13.         Restart Microsoft Exchange Information Store service for change take affect.     
  14.    
   
    If you are unsure of any of the above changes then please open an SR with Dell EMC support.