ViPR: VPLEX: Error 18000 seen on ViPR: Message: Could not retrieve HLU: Encountered an error when attempting to query used HLUs for initiators: Failed to get storage views from VPLEX (Failed getting storage views: 541)

Article Number: 516394                              Article Version:                               Article Type: Break Fix


Product:

VPLEX VS6


VPLEX VS6,VPLEX Local,VPLEX Metro,VPLEX GeoSynchrony 6.0 Patch 1,VPLEX GeoSynchrony 6.0 Patch 2,VPLEX GeoSynchrony 6.0 Service Pack 1,VPLEX GeoSynchrony 6.0 Service Pack 1 Patch 1,VPLEX GeoSynchrony 6.0 Service Pack 1 Patch 2

Issue:

Vipr logs errors:

Error 18000: Message: Message: Could not retrieve HLU: Encountered an error when attempting to query used HLUs for initiators: Failed to get storage views from VPLEX (Failed getting storage views: 541)

Description: Adding volumes to export (urn:storageos:ExportGroup:ecc8ada1-c3ae-43f9-9d76-9b3c6cb30d1e:vdc1) on storage array VPLEX+CKM001648XXXXX:CKM001651XXXXX
Description: Updating export (urn:storageos:ExportGroup:ecc8ada1-c3ae-43f9-9d76-9b3c6cb30d1e:vdc1) on storage array VPLEX+CKM001648XXXXX:CKM001651XXXXX

 

 

VPLEX logs:

RESTfulServlet: Error for user 'service' com.emc.vplex.restful.RESTfulException: export
Evaluation of <<export storage-view find -c cluster-1 -i storage-view  10:00:00:90:fa:7f:4c:90>> failed
          ​cause:        Command execution failed.
          cause:        com.emc.vplex.smsv2.business.BusinessException: Failure attempting to refresh properties 'storage-views' on Export.
          cause:        Failure attempting to refresh properties 'storage-views' on Export.
          cause:        Infinite or NaN

 

 

Cause:

This is an issue with the VPLEX CST JNI (Java Native Interface) portion of the code that may cause interference with other java threads.

 

 

Change:

User is trying to provision volumes from UNITY using Vipr software.

Problem found on VS6 Metro-FC Version 6.0.1.01.00.04

 

Resolution:

Permanent Fix:

This issue has been fixed in VPLEX GeoSynchrony 6.0 SP1 P4 and later. It is recommended that you upgrade your VPLEX to this version or a later version of the VPLEX GeoSynchrony code.