VNX2:Some SMB shares become unavailable to SMB2 clients after upgrade to 8.1.9.211 (Dell EMC Correctable)

           

   Article Number:     500801                                   Article Version: 10     Article Type:    Break Fix 
   

 


Product:

 

VNX2 Series

 

Issue:

 

 

Post upgrade to 8.1.9.211 File OE, some SMB2 clients lost access to CIFS shares   
   
    2017-06-07 10:14:07: KERNEL: 3: 3: ThreadsServicesSupervisor: Service:CIFS Pool:SMB2 BLOCKED for 1301 seconds: Server operations may be impacted .   
    2017-06-07 10:16:07: KERNEL: 3: 3: ThreadsServicesSupervisor: Service:CIFS Pool:SMB1 BLOCKED for 1319 seconds: Server operations may be impacted .   
    2017-06-07 10:29:07: KERNEL: 3: 3: ThreadsServicesSupervisor: Service:CIFS Pool:SMB2 BLOCKED for 2202 seconds: Server operations may be impacted .   
    2017-06-07 10:31:07: KERNEL: 3: 3: ThreadsServicesSupervisor: Service:CIFS Pool:SMB1 BLOCKED for 2220 seconds: Server operations may be impacted .   
   
    2017-06-07 10:38:13: TCP: 3: last message repeated 101 times   
    2017-06-07 10:38:13: TCP: 3: OpenStream() fails   
   
    Please note: This issue only affects VNX2 systems.  VNX1 systems are unaffected.
                                                           

 

 

Cause:

 

 

The latest release of the VNX2 software enables the use of Server Message Block version 2 (SMB2) as the dialect for secure channel communications between the VNX CIFS server and the Active Directory domain controller. Users can now disable the SMB1 protocol in their active directories. This reinforces security protocols on the Microsoft Remote Procedure Call (MSRPC) as an added level of security.   
   
    https://support.emc.com/docu80023_VNX-Operating-Environment-for-Block-05.33.009.5.184-and-05.33.009.5.186,-File-8.1.9.211,-and-Unisphere-1.3.9.1.184-Release-Notes.pdf?language=en_US   
   
    The SMB server becomes unavailable because the service threads are in deadlock in the communication path with the Windows Active Directory Domain Controller.   
     
                                                           

 

 

Change:

 

 

Upgrade to 8.1.9.211                                                           

 

 

Resolution:

 

 

This issue is addressed in VNX OE patch 8.1.9.21115.  Please contact Dell EMC Technical Support or your Authorized Service Partner and quote this Knowledgebase ID if you need to download this patch.  This patch will be rolled into a future full code release.   
   
    A workaround is available. Please contact Dell EMC Technical Support or your Authorized Service Partner and quote this Knowledgebase ID if you need to implement the workaround.