Connectrix Brocade B-Series: CMCNE migration from 14.1.0 to 14.2.0 fails while importing data.

           

   Article Number:     499955                                   Article Version: 5     Article Type:    Break Fix 
   

 


Product:

 

Connectrix Manager Converged Network Edition,Connectrix Manager Converged Network Edition 14.2.0,Connectrix,Connectrix B-Series Software

 

Issue:

 

 

   

      The database import fails during CMCNE upgrades. Therefore, the customer has to roll back to the previous version.    

                                                             

 

 

Cause:

 

 

   

      There could be a number of reasons for migration failure, such as an anti-virus could be blocking it or the CMCNE services are stopped, or a non-administrator user is trying to perform the upgrade.    

   
       
                                                             

 

 

Change:

 

 

Any CMCNE upgrade                                                           

 

 

Resolution:

 

 

    

      If customer is running CMCNE on a VM, they need  to be sure that :   

   
         
  •         If any anti-virus software is installed, make sure it is not running during the upgrade​. (VMware uses an agentless virus scanner for VM’s that blocks the start of database services and obstructs the upgrade. - Make sure this is disabled during the upgrade)     
  •      
  •         Since CMCNE is installed on a virtual machine, the resources need to be dedicated.     
  •    
Make sure user is logged in as Windows Administrator (not a user with administrator rights)    
     
   
       
                                                             

 

 

Notes:

 

 

   
    If the above considerations are met, and also the prerequisites mentioned in the "Pre-migration requirements" in the  USER GUIDE are met, and still the CMCNE upgrade fails:   

         
  1.         Make sure that old CMCNE is up and running.     
  2.      
  3.         Initiate upgrade to new CMCNE version.     
  4.      
  5.         If the event of any migration failure, DO NOT give Ok to roll back. Just leave the prompt unanswered.     
  6.      
  7.         Go to the new CMCNE home directory and collect (zip) all the folders and files in that directory. Move collected archive to a safe location.     
  8.      
  9.         Once step #4 has done, give the OK to roll back to old CMCNE     
  10.      
  11.         Once the roll back is complete, collect the migration failure logs along with zip archive from step 4, and engage Brocade for analysis.     
  12.