Data Protection Advisor 6.4 : DPA APP server hangs or crashes periodically.

           

   Article Number:     502738                                   Article Version: 3     Article Type:    Break Fix 
   

 


Product:

 

Data Protection Advisor 6.2,Data Protection Advisor 6.2 SP1,Data Protection Advisor 6.2 SP2,Data Protection Advisor 6.2 SP3,Data Protection Advisor 6.3,Data Protection Advisor 6.4

 

Issue:

 

 

DPA APP server hangs or crashes periodically.   
   
    Checking the executive.log file in the dpa/services/logs folder on the APP server you find the system is pinging the JVM with respond times of over 200 seconds with logs entries like the following.    
   
    2017/07/12 01:46:26.718 | Pinging the JVM took 284 seconds to respond.   
    2017/07/12 01:46:26.718 | Pinging the JVM took 280 seconds to respond.   
    2017/07/12 01:46:26.718 | Pinging the JVM took 276 seconds to respond.   
    2017/07/12 01:46:26.718 | Pinging the JVM took 272 seconds to respond.   
    2017/07/12 01:46:26.718 | Pinging the JVM took 267 seconds to respond.   
    2017/07/12 01:46:26.718 | Pinging the JVM took 263 seconds to respond.   
    2017/07/12 01:46:26.718 | Pinging the JVM took 259 seconds to respond.   
    2017/07/12 01:46:26.718 | Pinging the JVM took 255 seconds to respond.   
    2017/07/12 01:46:26.718 | Pinging the JVM took 251 seconds to respond.   
   
    You may also see memory errors in this log like the following:   
   
    2017/07/13 07:56:32.113 | Exception: java.lang.OutOfMemoryError thrown from the UncaughtExceptionHandler in thread "TxCleanupService,analysispolicycache,local"   
    2017/07/13 07:56:32.113 | Filter trigger matched.  Restarting JVM.
                                                           

 

 

Cause:

 

 

The Java Virtual Machine that DPA is running on, has run out of memory and the system is hung or crashed.                                                           

 

 

Resolution:

 

 

First stop the APP services and if possible reboot the server as this will clear memory and allow the server to start back up again.   
   
    This issue can be caused by several issues. Normally this is caused by reports that are large in data source or scope or time period that are not able to process with the memory available to DPA.    
   
    Check your scheduled reports, If you have more than 10 reports scheduled at one time split them up to run no more than 10 at a time, keep a 15 minute intervals between them.   
   
    If you are using the DPA APP agent for data collection consider moving that collection to another agent, as the agents will use memory to do data collection and that can limit the memory available to the APP.   
   
    If this happens often then memory addition to the DPA server will be required to resolve this issue. Once you have added memory you will have to tune DPA for that memory, so from an administrator command prompt or as root, navigate to <DPA install directory>/dpa/services/bin and run the following command:   
   
    dpa app tune 16GB                                      where 16GB is the amount of memory on the system, so this would be for a 16 GB server.   
        
    Then restart the DPA APP service.   
   
    Please contact Dell EMC Technical Support for further details or information.