Cannot manage SP A from Navisphere Manager browser, but instead get "unable to access Navi Security" message.

Product:


CLARiiON CX3 series

Product: CLARiiON CX Series

EMC SW: Navisphere Manager

 

Description:


Cannot manage SP A from Navisphere Manager browser, but instead get "unable to access Navi Security" message. 

 

Symptom:


Messages like the following in the CIMOM log:


NaviCimom!GenerateUserdumpUponHardwareException::GenerateStackTrace
NAVSocket!NAVSSLSocket::NAVSSLSocket
NAVSocket!NAVSSLSocket::acceptssl
NaviCimom!NAVHTTPServerListener::execute
NaviCimom!NAVThread::_threadWorker
kernel32!RegisterWaitForInputIdle


Unable to open Navisphere Manager


Cause:


This is a SSL certificate issue and is seen in early Release 19 bundles. When the CIMOM tries to regenerate the certificate, a known issue in openSSL (overflow issue) is encountered. Since SSL was not initialized, Naviseccli and the Navisphere Manager GUI do not work. By resetting the storage processor date back to 2000, the certificate gets created successfully. In this case CIMOM log message indicate that the SSL certificate was not initialized and so the Listener process is not working:

15-MAY-2008 01:15:08.988 -E- WebServer: Http Server Listener unable to listen on address and port: 10.14.123.45:678

 

Resolution:


The latest Release 19 patch (after patch 030) fixes this problem. 

Note: This problem has also been observed in FLARE Release 22, specifically 3.22.40.5.510.


If running FLARE Release 19 or earlier and the storage system cannot be upgraded, follow these steps:


  1. Use EMCRemote to log on to the SP.
  2. Run net stop k10governor from a command window. Set the year on the SP to 2000.
  3. Run net start k10governor from a command window.
  4. Run some navicli commands (for example, navicli getagent and navicli getcrus).
  5. Repeat Step 2.
  6. Set the year on the SP back to 2008.
  7. Repeat Step 3.
  8. Check to see whether you can browse to the SP.


If running Release 22  or later, follow these steps:


  1. Use EMCRemote to log on to the SP using.
  2. Stop the CIMOM process using Task Manager. If you are unable to do this, issue the net stop k10governor command from a command window.
  3. Set the year on the SP to 2000.
  4. If you had to stop k10governor, issue the net start k10governor command from a command window.
  5. Run some naviseccli commands (for example, naviseccli getagent and naviseccli getcrus).
  6. Repeat Step 2.
  7. Set the year on the SP back to 2008.
  8. Repeat Step 3.
  9. Check to see whether you can browse to the SP.

 

If there is still a problem, EMC Navisphere Engineering must be involved. To do this please engage a Level 2 Engineer. 


Note:


The following operations were performed to resolve the issue but they did not work:

  • Destroyed the domain security.
  • Destroyed the domain.
  • Rebooted SP A. (SP B could be managed.)

 

For more information refer to Primus” emc192906 “.