Ever since the General Availability (GA) of InsightIQ v3.2.2, we have received a tremendous amount of interest from our customers to upgrade to it.

 

Recently a customer tried to install InsightIQ v3.2.2 on an existing Linux machine that had been patched to a newer version of openssl than what the InsightIQ installer expects.  The dependency check failed.

 

This blog is aims to describe the fix in the case that you run into this issue.

 

Summary of the problem:

               Upon installing InsightIQ, IIQ installer fails due to a failed dependency resolution.

 

Summary of the fix:

Install the openssl-devel package prior to installing InsightIQ, with the command:

sudo yum install openssl-devel.x86_64

 

Detail of the problem:

During dependency resolution, installer returns the following error, highlighted in yellow:

[12:51:35] rchang@VNODE0168:[~]:sudo sh install-insightiq-3.2.2.0007.sh

Verifying archive integrity... All good.

Uncompressing EMC Isilon InsightIQ - 3.2.2.0007 - Self Extracting Installer..........................

 

This script automates the installation or upgrade of InsightIQ.  If you are

running a version of InsightIQ that can be upgraded by this version, the

upgrade will occur automatically.  If you are trying to upgrade an unsupported

version, the script will exit.  If you are installing on a new system, the

script will perform a clean install.

 

Are you ready to proceed with the installation?

Please enter (Y)es or (N)o followed by [ENTER] >>> Y

 

.

.

.

---> Package openssl-devel.x86_64 0:1.0.1e-30.el6.11 will be installed

--> Processing Dependency: openssl = 1.0.1e-30.el6.11 for package: openssl-devel-1.0.1e-30.el6.11.x86_64

.

.

.

---> Package openssl-devel.x86_64 0:1.0.1e-30.el6.11 will be installed

--> Processing Dependency: openssl = 1.0.1e-30.el6.11 for package: openssl-devel-1.0.1e-30.el6.11.x86_64

--> Running transaction check

.

.

.

--> Package openssl-devel.x86_64 0:1.0.1e-30.el6.11 will be installed

-> Processing Dependency: openssl = 1.0.1e-30.el6.11 for package: openssl-devel-1.0.1e-30.el6.11.x86_64

-> Finished Dependency Resolution

Error: Package: openssl-devel-1.0.1e-30.el6.11.x86_64 (/openssl-devel-1.0.1e-30.el6.11.x86_64)

Requires: openssl = 1.0.1e-30.el6.11

Installed: openssl-1.0.1e-42.el6.x86_64 (@base)

openssl = 1.0.1e-42.el6

You could try using --skip-broken to work around the problem

You could try running: rpm -Va --nofiles --nodigest

 

Detail of the fix:

Install openssl-devel.x86_64 with this command:

sudo yum install openssl-devel.x86_64


[12:57:22] rchang@VNODE0168:[~]:sudo yum install openssl-devel.x86_64

[sudo] password for rchang:

Loaded plugins: fastestmirror, security

Setting up Install Process

Repository base is listed more than once in the configuration

Repository updates is listed more than once in the configuration

Repository extras is listed more than once in the configuration

Repository centosplus is listed more than once in the configuration

Repository contrib is listed more than once in the configuration

Loading mirror speeds from cached hostfile

* base: mirror.tzulo.com

* extras: centos.mbni.med.umich.edu

* updates: mirror.netdepot.com

Resolving Dependencies

--> Running transaction check

---> Package openssl-devel.x86_64 0:1.0.1e-42.el6 will be installed

--> Processing Dependency: zlib-devel for package: openssl-devel-1.0.1e-42.el6.x86_64

--> Processing Dependency: krb5-devel for package: openssl-devel-1.0.1e-42.el6.x86_64

--> Running transaction check

---> Package krb5-devel.x86_64 0:1.10.3-42.el6 will be installed

--> Processing Dependency: libselinux-devel for package: krb5-devel-1.10.3-42.el6.x86_64

--> Processing Dependency: libcom_err-devel for package: krb5-devel-1.10.3-42.el6.x86_64

--> Processing Dependency: keyutils-libs-devel for package: krb5-devel-1.10.3-42.el6.x86_64

---> Package zlib-devel.x86_64 0:1.2.3-29.el6 will be installed

--> Running transaction check

---> Package keyutils-libs-devel.x86_64 0:1.4-5.el6 will be installed

---> Package libcom_err-devel.x86_64 0:1.41.12-22.el6 will be installed

---> Package libselinux-devel.x86_64 0:2.0.94-5.8.el6 will be installed

--> Processing Dependency: libsepol-devel >= 2.0.32-1 for package: libselinux-devel-2.0.94-5.8.el6.x86_64

--> Processing Dependency: pkgconfig(libsepol) for package: libselinux-devel-2.0.94-5.8.el6.x86_64

--> Running transaction check

---> Package libsepol-devel.x86_64 0:2.0.41-4.el6 will be installed

--> Finished Dependency Resolution

 

Dependencies Resolved

 

===========================================================================================================================================================================

Package Arch Version Repository Size

===========================================================================================================================================================================

Installing:

openssl-devel x86_64 1.0.1e-42.el6 base 1.2 M

Installing for dependencies:

keyutils-libs-devel x86_64 1.4-5.el6 base 29 k

krb5-devel x86_64 1.10.3-42.el6 base 502 k

libcom_err-devel x86_64 1.41.12-22.el6 base 33 k

libselinux-devel x86_64 2.0.94-5.8.el6 base 137 k

libsepol-devel x86_64 2.0.41-4.el6 base 64 k

zlib-devel x86_64 1.2.3-29.el6 base 44 k

 

Transaction Summary

===========================================================================================================================================================================

Install       7 Package(s)

 

Total download size: 2.0 M

Installed size: 4.9 M

Is this ok [y/N]: Y

.

.

.

Installed:

  openssl-devel.x86_64 0:1.0.1e-42.el6

 

Dependency Installed:

keyutils-libs-devel.x86_64 0:1.4-5.el6 krb5-devel.x86_64 0:1.10.3-42.el6 libcom_err-devel.x86_64 0:1.41.12-22.el6    libselinux-devel.x86_64 0:2.0.94-5.8.el6

libsepol-devel.x86_64 0:2.0.41-4.el6 zlib-devel.x86_64 0:1.2.3-29.el6

 

Complete!

 

Then re-try InsightIQ installation again.  InsightIQ will install and work swimmingly.